Audacity does not respond


I was trying to install last version of Audacity, in my mac. It asked me if I would like to instal my vst plugins who i had in my computer, and I answered yes, and after install this, the program didn´t work. Always the same, " The program don´t answer".
I tried to install all last versions of audacity, and any didn´t work…

I tried to deleted all plugins of my folder´s plugins, and idem…

I have a mac osx Mac OS X 10.6.4 (10F569)
kernel: Darwin 10.4.0

Is possible are there any registration plugins of Audacity in my mac I didn´t know??

Please help me!!!

Audio Unit effects load after Audacity loads your checkmarked VST plug-ins.

So even if you removed your VST plug-ins from the locations in which Audacity searches for VST effects (the Audacity plug-ins folder, ~/Library/Audio/Plug-Ins/VST and /Library/Audio/Plug-Ins/VST), an individual Audio Unit might be the problem, or you may have so many Audio Units that Audacity is taking too long to load them all. Too many Audio Units is the most likely cause.

I would suggest force quitting Audacity in Activity Monitor then download this: . That build should defer loading of Audio Units until you choose them from the Effect menu, so it should start if Audio Units are the problem.

If Audacity 2.0.5 above still hangs, then VST’s are probably the issue. You can disable all VST’s in the audacity .cfg settings file as described here: but then you won’t be able to use VST’s in Audacity.

So I suggest instead opening Finder, choose “Go” > “Go to Folder” and open ~/Library/Logs/DiagnosticReports/ . If there is a report there from the same time as the problems happen, please attach the report. Then it may be possible to see if an individual effect is causing the problem. Please see here for how to attach files: .


Hello Gale!

Thanks for quick reply!

I attached the file report.
Anyway, I tried with the 2.0.5 version and it was run withuot problem. After I disabled the Vst and Au plugins, and the problem disappeared!!! thanks so much!!!

And Now that is my cuestion:

which version you advise me to use? 2.0.4, or 2.0.5?

Thanks again!!

Did you disable Audio Units and VST in audacity.cfg, or in some other way?

The should have prevented a crash due to Audio Units without you having to disable Audio Units yourself in audacity.cfg. Are you using that r12571 plus version?

You don’t seem to have attached the Mac crash report. Please see for how to attach files.

It is probably better for you to use that 2.0.5 version (12571 plus). But you cannot use Open with in Finder or drag a file to the Audacity icon with that version - you have to open files using the Audacity menus. That problem is already fixed in a later build of 2.0.5-alpha, but can you manage for now without “Open with” and dragging files to the Audacity icon?



At first I was trying to disable Au plugins in a audacity.cfg file, and I tried to open the 2.0.4 version and didn´t work. I thougth might be by the txt archive and the format of it. After I trying a few times to change the format of the text, unable to start the 2.0.4 version, I tried to run the 2.0.5 1257 plus version, and worked withuot problem. And them I disable the vst and au plugins.

Now the version 2.0.4 work, but whem I try to import audio file, the sofware crash.

Atached the txt file with the last diagnostic report.

The version 2.0.5 1257 plus work very well, but I would like to Know what happen with the 2.0.4, just curious…

Thank you Gale!!
Diagnostic report Audacity.txt (124 KB)

Thanks for the explanation.

No single plug-in is mentioned in your report. I would guess you have too many Audio Unit plug-ins on your system for Audacity to start properly, with the result that it “hangs”. This should be fixed if we commit the code in that “12571-plus” version.

Now that you have disabled AU and VST plug-ins in Audacity, you could run this version instead: . That version has fixed the import crashes and also fixed most of the problems when opening a file from Finder did not open the file in Audacity.


Thanks you very much gale! Greetings!!

Juan Llavero

That code to defer load of Audio Units until you request them from the Effect menu has been committed so will be in the next 2.0.5 release.