Audacity does not record with windows 10

Audacity does not record since i have windows 10 :cry: :cry: :cry: .and i have the same problem with another notebook too :blush: :blush: :blush: .
I use: Windows 10
Audacity 2.4.2
Notebook Lenovo ideapad s145
Behringer guitar link ucg102
When i try to record it show me this: error opening open device. error code: -9999 Unanticipated host error.

Thank you.

I bought a turntable with USB and first I thougth, the error message stands in conjunction with this device. But windows build in recorder is able to save the USB-audio stream und Audacity can’t open ANY audio device for recording. All known permissions for device usage (microphone…) exist.
Do you found a solution?

Do you have the most recent version (2.4.2) of Audacity? https://www.audacityteam.org/download/windows/

Have you tried rebooting the machine ?

To be sure, I did it again. But unfortunately there is no change in the behaviour.
I use Windows 10 Build 2004.
I noticed, that there have been several changes regarding security and microphone in the last years.
BTW:
Audacity never appears in the “last usage”-application list(s) in Windows Setting/Security/Microphone while Microsoft Teams, Cisco Webex, Zoom and other recording programs do this. I think it’s a access denied problem, but I’ve no idea why. I tried recording with Audacity run as Administrator too. No improvement :frowning: .

As a developer I wonder which interface Audacity tries to use.

Either MME, DirectSound (emulated on Win 10) or WASAPI. Select your preferred API via the “host” setting in the Device Toolbar.

what steve says. :smiley: See also the next post.

If you think it is a microphone access problem (and I agree with you) as a test you could go to microphone privacy settings and “Change” access to “On” (for all devices). See if that corrects the problem. :smiley:

When Audacity first starts it builds a list of all audio devices on your system. If it has a problem with one of them, it can sometimes prevent Audacity form seeing the others. If Audacity cannot find ANY audio devices, you may be able to discover the one causing problems. Try disabling all of your sound devices one by one to find the one causing problems. Restart Audacity after you do so (or Tools > Rescan).

Also, did you say that you were on Audacity 2.4.2 ?

Thanks for answering.
I read
https://manual.audacityteam.org
https://manual.audacityteam.org/man/faq.html
https://manual.audacityteam.org/man/faq_errors.html#sound_device
https://manual.audacityteam.org/man/error_opening_sound_device.html#codes
and reviewed all hints.
But I’ve to say, I had it done before writing into this forum :sunglasses: .
So I repeat: All “Apps” and desktop applications are allowed to access the microphone.
This is what the windows settings say. But, may be it’s Kaspersky. Unfortunately I’m not allowed to stop it for testing. It’s given by a group policy rule. I’ll will ask my administrator (I’m allowed to use the computer for business and private (with restrictions)).
FYI:
I use 2.4.2
The lists for Audio host, Recording device, Channels and Playback are always filled correctly.