Audacity does not prompt for microphone on Catalina

Hi all,

I’m doing some beta testing currently for a university. We are testing 2.3.2 on the latest beta (19A558d).

The problem we are finding is that if Audacity is installed and run for the first time on a machine with Catalina, it never prompts for microphone access. Browsing manually to Security & Privacy does not show any option for Audacity to be allowed, so it seems that the request is not registered by the OS at all.

The end result is that Audacity allows the microphone to be selected for recording, but no signal is captured.

I have also used the trick posted by another user to run the app from Terminal in the hope that the OS will see Terminal prompt for microphone access, but this has not helped for us. I have reproduced this behaviour on two different Macs.

Has anyone else has this issue?


I’m having the same issue.

See this Forum thread:


Hi! Thanks for the reply. I have tried everything in that thread, including running from Terminal, as user and/or root, yet nothing will bring up the prompt and it is never shown in the Privacy Sys Prefs.

I’ve reproduced this on 3 different test Macs now (iMac 2010, MBP 2015, MBP 2016).

Appreciate any suggestions…

Update… Seems as if since going to build 19A558d, the Terminal trick is now prompting for Microphone.

I am still as yet unable to get Audacity to prompt or record without doing this. Is there any fix in the pipeline for these PPPC issues from Mojave?

See this Forum announcement Audacity under macOS 10.15 Catalina

And many thanks to noraa for posting that workaround


I am having this issue with Audacity not asking for permission to use my mic. I tried the Terminal trick and it is still not working. Any advice??

When you install the current version of Audacity (2.4.1), you should be prompted on first run for permission to use the mic.
The current version of Audacity is available via the Audacity website: Audacity ® | Download for Mac OS

I’m having this exact issue and I’ve done every work around (downloaded the updated version of audacity, started from terminal, etc.) I neither have the option of Audacity in my Microphone aspect of Privacy and I can not therefore get any of the workaround to record onto my computer using my zoom recorder. Has anyone actually found a way to get this to work when Audacity is being used for the first time within Catalina?

And is there a hardware fix (such as a different microphone setup?)

Thank you!