Audacity does not play the whole wav sound on Fedora

I am using Audacity 2.1.2 on Fedora an editing a .wav sound and I am pretty sure after removing parts of the beginning and the end that the playback does NOT play the whole sound to the end.
When I play the same exported sound with the vlc player it plays the whole sound.

I use pulseaudio as playback. Is this a bug?

Try reducing the “Audio to buffer” setting in “Edit > Preferences > Recording / Latency”.
Note that if set too low, both recording and playback may stutter, and if also using Pulseaudio Audacity may freeze. Low buffer settings tend to work best when using the “hw” device options in the device toolbar.

It’s “normal” with Audacity on Linux, unless you use the low latency JACK API, which is fiddly to set up.

You can just type K to go to the end of the track, and generate a little silence.