Audacity Crashing...

Hi, I’m running MacOS 10.12.6 and Audacity keeps crashing with me as well. I get the following:

Process: Audacity [31389]
Path: /Applications/
Identifier: org.audacityteam.audacity
Version: (
Code Type: X86 (Native)
Parent Process: ??? [1]
Responsible: Audacity [31389]
User ID: 502

Date/Time: 2018-05-20 12:03:42.212 -0700
OS Version: Mac OS X 10.12.6 (16G1114)
Report Version: 12
Anonymous UUID: 47F43576-F029-DD4D-C57E-65F9E32784F1

Sleep/Wake UUID: A3988155-B93A-49F3-B5D1-B0FC2077E772

Time Awake Since Boot: 89000 seconds
Time Since Wake: 1400 seconds

System Integrity Protection: enabled

Crashed Thread: 11

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Application Specific Information:
Assertion failed: (!err), function AudioIOProc, file /Users/paullicameli/GitHub/audacity/lib-src/portaudio-v19/src/hostapi/coreaudio/pa_mac_core.c, line 2482.

Any ideas? I tried deleting Audacity and the folder under ~/Library/Application Support/audacity as suggested in other posts but that didn’t work. Thanks!

keeps crashing when you do what?

What are the steps to reproduce?


It crashes whenever I try to record. So all I need to do is click on the record button. Sometimes it will crash after a couple seconds, other times after a minute or so. Thanks!

mahmoud, I keep getting same crash when record is pressed. hoping there is a fix for this.

What version of Audacity, please?

I have the latest, 2.2.2.

I am having the same problem. It records for a few seconds and then quits.
Audacity 2.2.2

Just to update the group (in case it helps anyone), but I tried again on a new Macbook Pro that I recently got and it worked fine (on 2.2.2) and was able to go through with the full recording of the cassette tape. So if you have access to a newer Mac, try that.