Audacity crashing on startup, generating debug report


Audacity 2.4.2 (also 3.0.2). Windows 10 home.
I try starting audacity, the small logo pops up on the screen, then a debug report is generated. I’ve uninstalled and reinstalled several times, trying different hard drives, and resetting preferences, but it keeps doing this. I reinstalled my OS a few weeks ago, migrated to a new SSD, and everything worked fine. Shipped the PC across the country (with good packaging) and now it won’t boot. I’ve reseated the ram, gpu, and checked all physical connections, everything seems to be fine. It’s on an nvme ssd.
I’m attaching the debug report. The “log” file is empty and thus won’t upload to here or dropbox, not sure what to do with that. the audacity.dmp file is in the dropbox link.

Any help would be greatly appreciated!
pluginsettings.txt (27 Bytes)
pluginregistry.txt (53.6 KB)
audacity.txt (586 Bytes)
Audacity.xml (11.6 KB)

It would seem that is the number #1 priority right now.
MemTest86 might be a good place to start (it tests that the RAM is all working correctly).

If that checks out OK, check the drives. Many manufacturers of SSDs provide utilities on their websites for drive testing (Example: Seagate provide “SeaTools”)

Done and done, they all came back fine. Everything else on the computer runs fine, it’s just Audacity throwing a fit.

What did you mean by “now it won’t boot.”?

I should be more specific
Audacity won’t load. I launch the program, then get the debug screen.

What is “WH-1000XM3 Stereo”?
Some sort of headphones?

Yes, my sony noise cancelling headphones. I haven’t had issues with them in the past. I can try starting audacity with them off and report if that changes anything.

Please do.

no change, still crashes when I run audacity. Any idea what the debug files are saying?

As far as I can see, they don’t tell us much other than that Audacity crashed quite early during startup.

If it had only been with 3.0.2, I would have suspected the cause to be an unknown bug in Audacity, but the fact that it also happens in Audacity 2.4.2 (as used by millions of people), I’m more inclined to think that it is something peculiar about your system (though I don’t know what).

What security products are you using, and are they up to date?

Also, a crash could be caused by an initialization failure of a plug-in or the audio system. I don’t have any experience with the .dmp files, but you could try deleting all of your plug-ins (or just renaming your …/Appdata/Roaming/audacity directory). Also, you can try removing/disabling any/all of your audio devices/drivers and any external video (e.g. HDMI) devices/drivers.

Malware bytes, and it’s up to date. I can also get Norton installed and running if recommended, I do have a license I can use. I can try turning secure boot on/off, I had to do that when I cloned my boot drive. But Audacity did work after doing all that. I shipped my mini itx pc in my luggage from east to west coast and back, and it was packed so nothing could jiggle (packing inside the case, inside the box, around the box, then the suitcase, I was thorough). this is the only program effected, which doesn’t make any sense to me. all of the benchmarks and system burn-ins are showing no issues.

Because re-installing it isn’t working it, I’m wondering if there are some files hidden somewhere that aren’t getting installed, and then when reinstalling, are causing the crashing issue. I don’t know where to even start looking for extra files or anything. I could back up all my audacity files to an external drive to get them completely off my computer, but after that I’m out of ideas. I don’t want to do a fresh OS install, I did that in May and it took far too long to move my files around.

I got audacity to load! I had to delete the registry files for it and also scrub nahimic from my computer.

New problem: “Audacity did not recognize the type of the file ‘D:\users.…aup3’. Try installing FFmpeg. For uncompressed files, also try File > Import > Raw Data.”
I had it reset my preferences so I’m guessing I have to reinstall the plug-ins, too?

“Nahimic” the audio driver /surround sound thing?

That’ll be because you delete the registry files associating AUP3 files with Audacity.
Try uninstalling Audacity, then reinstall. This may be one of the very rare times that reinstalling Audacity actually fixes something.

Yes, Nahimic is an MSI (subsidiary?) program and audio driver that acts like malware, apparently, and can open up your computer to other threats.
I couldn’t open the AUP3 file because I was trying to do so with audacity 2.4.2 :laughing:
installed 3.0.2 and everything works normally. Thanks for the help!

Super, thanks for the update.

Re. Nahimic:

If I’d known what to look for, I could have found that in the “Audacity.xml” file that you posted

<module path="C:\ProgramData\ ... \NahimicOSD.dll"

From searching on-line, it looks like it is a legitimate program, but with a lot of reported problems, especially for computers with on-board Realtek audio.