Audacity crashing (hanging, freezing) when using punch and roll

I’m experiencing this issue with Audacity 2.2.1 and 2.2.2 on Mac Catalina 10.15.1. (I’m using Terminal to open, via Automator.)

When I use punch and roll, Audacity freezes. It looks like it’s recording, but when I stop the recording, I get the beach ball. As of yesterday, it was working, but today, it’s not. When I force quit, I can open the recovered file. I lose the new recording (after the point where I put my cursor for punch and roll.)

What I’ve tried:
-Restart computer
-Upgrade to 2.3.3. (Punch and roll works, but I get a bunch of “dropouts.”) Downgrading back to 2.2.1 or 2.2.2, I have the punch and roll issue but no dropouts.
-Based on a previous forum post, I changed the buffer length (down to 0, up to 130 and 160), but the problem remains.

This happens whether I open my recovered file or start a new file.

For now, I’ll proceed without punch and roll; that’s how I used to record. But if anyone has a fix, I’d love to hear it.

This puzzles me as those are built as 32-bit applications and should not run on Catalina which only runs 64-bit applications :confused:


Apple say that Catalina cannot run 32-bit applications.
Audacity 2.2.1 and 2.2.2 are 32-bit applications.

Same thing is happening to me. I tried changing which USB port my interface was plugged into and that worked for a bit but then it started happening again. I also tried closing and restarting audacity and unplugging then plugging back in and then starting audacity again. Every once in a while, it decides to work fine. The keyboard shortcut is intact in the preferences. Windows 10. Audacity 2.3.3

I discovered this is a problem with the drivers. Audacity does not support ASIO drivers. I just started using the EVO4 interface but as far as I can tell, most interfaces also require ASIO drivers. Audacity uses MME by default. I tried switching to WASAPI but that freezes the whole DAW. Has anyone solved this issue?

@AnnemarieR Are you aware that this is the macOS part of the forum?
(And as you say, Audacity releases do not support ASIO