Audacity crashes WHILE saving project.

Hi… I’ve been recently upset at this issue that occured. I started my soundscape project “Godzilla vs Gigan first person point view” 2 days ago…
I am on day 3 of working on it. Recently as of getting to 3 minutes of audio, I noticed the playbacks, stops and even saving would delay and lag. Sometimes clicking doing my usual work audacity would even crash. But, I was able to recover the files and continue on. I never knew this, at 8:30AM EST would happen.
I was about to get off, I was working on the audio project 24 hours straight yesterday, about to go to bed. While I was saving, I clicked the usual, “Save project as” and after I clicked that, it saved. But while it was saving, before it could finish, audacity crashes. I always click “Cancel” when a program stops responding when it says “Windows is trying to find the solution to the problem”. After that, I re-opened the program once it closed, the automatic recovery only recovered a secondary piece I had open that I earlier dragged into the soundscape. I’m left with just a clean-empty slate of nothingness. I close audacity, look on my desktop to find that the .aup is now a white file icon and is named “Godzilla vs Gigan first person point view.aup.bak” I don’t see much of a problem once I try opening this bak, It is considered “raw data” I open it and all I get is 2 seconds of random static. Yeah-I was about to go under the 6 minute stage of the audio-project, and I get is 2 seconds. I still have the .bak and the project folder with all these folders inside. I followed an old tutorial from 2012 to try and fix this problem since I never knew about it, followed it all almost right intill I opened the autosave I found in the audacity program files by just dragging the file into audacity, all I got was emptyness… This really makes me upset and I want to finish my work ASAP, I did not spend 3 days of non-stop work for nothing in return. Please help me!

I am using Windows 7 home premium Dell laptop.
I just realised my version is audacity 2.0.6 But I hope someone out there will still give the helping hand, not the finger.

How large is this project (how many tracks and how long are the tracks)? How much RAM and disk space do you have, and what is the processor speed? You might be trying to push the machine too far.

Where did you get Audacity 2.0.6 from? Audacity supplied by us should not be writing AUP.BAK files, unless such a file is produced as a “left-over” when the new AUP that should have replaced it can’t be written.

AUP or AUP.BAK files are text files, not audio data, so you cannot open them with Import Raw Data.

What tutorial you were following or what were you trying? Given you have been editing the project heavily, there is no way to recover it without the AUTOSAVE file or (some kind of) AUP file to determine how to piece it together. You can drag AU files into Audacity from the project’s _data folder, but you will have no idea where each file belongs.

We can’t guarantee we can fix anything, but please attach the AUP.BAK and AUTOSAVE files. Please see here for how to attach files:


Well, considered how many audio clips, ambiences, voice scripts… Probably 50+ I’ve also on certain ambiences, cutt them and copy+pasted portions of them to another section so I can change the orientation the audio is heard, so say you hear a city ambience from a closed window, it’s on the left ear, you hear the character get out of his bed, the city ambience will quickly switch in miliseconds from left - right, then back to right ear. that might be cause of the delay also, not just the amount of files and length

I got Audacity from your DEFAULT page probably a few months back…-:

Ah. Well it the program claimed it was “Raw Data” and I did what it said, also to mention that it replaced the .aup, same EXACT spot where the .aup was with this .bak file.

I was emotionally disturbed atm while I was reading this topic earlier this morning, so I probably made my issue worse:
I was reading it and listening about the autosave location, I found it but… I dragged it into an emtpy sheet of audacity, I forgot what happens next but I do know, that autosave vanished out of thin-air, it is no where to be found, I don’t know what to do about this part though… I’ll send what I can to you.

It won’t allow me to send you the .bak file via Attatchment so, I’ll send to you via mediafire along with the datafolder in a zip, it is going to take some time to upload though-I don’t have an autosave but-I hope this helps atleast…

Okay here it is, It’s the datafolder + the .bak file together compressed in a zip.

Also, when I did download Audacity from your site- I used the .exe installer. -just pointing that out…

Sorry, but I am not willing to download 2 GB to obtain the AUP.BAK file. Could you perhaps place the AUP.BAK in a zip file, or simply rename it to “AUP” for the purpose of attaching it.

The AUTOSAVE file should not have disappeared when you dragged it into Audacity. Could you have another look in Users<your user name>\AppData\Roaming\Audacity\AutoSave\ for it? Also if there is .TMP file in there could you attach that. Rename anything you cannot attach to TXT extension.


I’ve checked that from that tutorial, it isn’t there-I doublechecked as you asked, nothing is there, it is empty-even when I was following that tutorial; There was the autosave, but it “Vanished” as I said earlier also, there was never a .TMP file there… I don’t know why, I guess my version of Audacity is just very glitchy, but I will update once this problem is resolved.
Here’s just the AUP.BAK project-file-backup…? File… thingy?

The AUP file appears to refer to 5975 AU files and to be in good shape from a syntax point of view.

Could you restart Audacity, open that AUP file then save the contents of Help > Show Log… . It is saved as a text file. Please attach it here.


:smiley: :smiley: :smiley: This sounds like good news, it brings alot of excitement to me-I have that feeling you will possibly be able to fix it for me…
Help SHOW LOG.txt (2.06 KB)

You tried to open or import a file called “AUP” without any extension, so it failed.

Name your AUP.BAK file “Godzilla Vs Gigan City In Anarchy First-Person view.aup” , use File > Open… to open that file, then attach the log for that action.


Wow. I never thought about this most common problem with alot of applications on windows is: The fact that renaming a file can cause errors and didn’t realise that this file was still intact or wasn’t even removed. I’m guessing if I reopen it and click “Continue” it should be back where I left off with no signs of damage-thus meaning I can finish where I left off…?
Show Log.txt (341 KB)

You have 2376 AU files in the project’s _data folder that are not referenced in the AUP file. These are called “orphan block files” in the log. If this AUP.BAK file (now renamed to AUP extension) is a very old state of the project, this is not really unexpected.

What you needed is the AUTOSAVE file, which would have been the state of the project when you tried to save it. Even if it gave incorrect audio it should have shown us a more relevant log file to understand “why” the audio was incorrect. No one told you to drag the AUTOSAVE file into Audacity, though doing that should not make it disappear. Have you tried searching the entire computer for AUTOSAVE files? Perhaps you dragged that file into another folder when you tried to drag it into Audacity?

In a project you were spending hours on, you should have been doing File > Save Project As… at least every few hours to give you incremental backups you could go back to.


I clicked continue, You’ll be surprised. It’s at the exact state it was when I SAVED IT right when it crashed WHILE SAVING IT… Wow. :open_mouth:
I’ve searched for the autosave on “Computer” and didn’t find any results But- the only slight problem the project has is atleast, every 30 seconds when previewing the audio playback, it echoes alot, sometimes slows-down the audio speed-Basically the exact type of disaster you get when a Casset’s TAPE is damaged… But I’m dealing with it, I exported a Teaser Preview of it just to see how it was, Nothing was damaged at ALL, the only problem is that my soundart was more ment for headsets and the bass and trebble are too high for speakers, car speakers and surround sound.

I did choose “SAVE AS” when I saved, but that was every time I was about to-go-to-sleep… I will now often when I complete a certain goal on the soundscape or anything in the future big- “SAVE AS” every so often… Thank you so much for your help. Now I can finish this and soon hopefully post it on YOUTUBE or maybe a showcase on the Audacity forums if there is a board directly for that type of stuff-is there…?

I’m glad the AUP.BAK file seemed to be as the project was when you were saving it :smiley: Yes I am a bit surprised given the AUTOSAVE file was still there (for a time). But it could have been an old AUTOSAVE file that never got deleted.

Orphan files are also normal when you recover a crashed project and recovery works. The orphan files are files that were meant for Undo/Redo.

Your project was huge (about 6 GB even if it was just saved and so had no extra files present for Undo/Redo). I would suggest shutting down all other applications you can while working on such a project (as well as periodic File > Save Project As… to a new project name).

Don’t forget to update Audacity. 2.1.1 is up right now and 2.1.2 should be out soon.

You are welcome to post a link to your creation on You could post on Audacity’s Soundcloud group and link to that post.