Audacity crashes when using USB mic

Hi all,

I’m on Debian 10, running Audacity 2.2.2, and I believe it’s my distribution’s release. I’m a Linux newbie so that’s my best guess.

The problem: I have a USB mic plugged in and I’m trying to record using that as the input. It’s a cheap Jeemak PC20, but I know it works because I tried it on another computer running Windows 10.

Any time I try to record using that or the external webcam (also USB), Audacity freezes. The laptop’s onboard mic seems to work ok, but I need the better audio quality of the line-in mic.

What do I need to do? Thanks in advance.

Try disconnecting the webcam. Reboot the computer, then launch Audacity. Select the USB mic as your recording device in the Device Toolbar. Does that work?

No, it still freezes immediately. I can record with the onboard mic but as soon as I select the USB mic and hit record, it locks up.

Try installing “Gnome Sound Recorder” and see if the mic works with that.
(To set which mic to use, start recording and open the Audio Mixer. In the “Recording” tab, select the USB device.)

The version of GNOME Sound Recorder I have doesn’t seem to have that option. I went into Settings and told the system to use the USB mic and then tried Sound Recorder. No luck but at least it didn’t freeze like Audacity did.

Gnome Sound Recorder uses PulseAudio by default.
To change the device that it uses you need to select the device in the system “Audio Mixer” (AKA “PulseAudio Volume Control”).

An easy way to open PulseAudio Volume Control is from the command line:


  1. Start Gnome Sound Recorder recording, then
  2. “F2” to open a command line and enter: pavucontrol
  3. Then switch to the “Recording” tab and select the USB device as the recording device for Gnome Sound Recorder.

Tried that, it doesn’t register any audio coming in from the usb mic. The onboard mic and the webcam both register audio.

So it seems that the mic is the problem.
Have you tried using it in a different USB port?

I’ve tried the mic on different USB ports, no change. I’ve tried the webcam on the same USB ports and that works fine.
I’ve also tried the mic on a Windows machine and it works there.

I noticed on this site: Jeemak PC20 USB Microphone Kit for Computer Microphone Set (USA ONLY) – Campark - Focus on Cameras
it says:

Note: If you are unable to use the microphone due to the version of your computer system or other issues, please contact JEEMAK directly and we will help you to solve the problem promptly.

Perhaps worth giving that a go.

Already in communication with them, and looking at Debian help forums at the same time. Just trying a couple different avenues at once.