Audacity crashes frequently while using spacebar [SOLVED]


I really have big problem in my daily use of audacity (2.0.5) on my Mint 17 system. The program ALWAYS crash, sooner or later when I use it. It is very annoying, and sometimes it force me to use windows instead. In windows it never crashes.

I’ve found a bug which more or less is spot on my problem:

The difference is that I do not need to hit the spacebar 6-7 times a second to make audacity crash. In a typical session I USE the spacebar a lot, to start and stop the playback. The reason is that I’m using Audacity for transcribing music (note by note), and in this process it is very handy to loop small pieces of the music. After I’ve figured out what is played, I move on to the next section, loop it, and so on.

No one of the suggested workarounds works for me:
*) Setting PULSE_LATENCY_MSEC=30 might improve the situation a bit, but Audacity still crashes often enough to really annoy me.
*) Bypass Pulseaudio by setting the playback and recording device to an ALSA (hw) choice, simply doesn’t work. It just gives an error message.
*) Uninstalling pulseaudio isn’t really an option either

The issue seems to be very old. I found a forum post from 2009

Is there anything I can do?

Any help appreciated!

You could try the launch workaround but with a higher value. To test:
Press F2 to open a command prompt, then enter:

env PULSE_LATENCY_MSEC=300 audacity

The hw option will give an error if anything else is accessing the sound system. If the launch workaround does not work for you we can investigate this option further.

Setting PULSE_LATENCY_MSEC=300 solved my problem.

Thanks a lot for the help, Steve!