Audacity crashed right after saving (not sure if it's saved successfully)

Hello everyone,

I was recording with audacity, it was completely fine at the beginning, but when I open an old file which already has recording inside, and recorded just a few lines more and Audacity started to become really slow, and I kepte saving the file every time I edited the track, at the end the app crashed.

And when I tried to relaunch the app, the auto recovery couldn’t open the file either. I restart the computer, still can’t open the file, everytime when I tried to recover the file or just simply open the file the app freezes.

I’ve tried to find solutions on Forums for hours but only found something for older version of Audacity.
the file was recorded with 3.0.2 But now I’ve installed the new version 3.0.5 (I thought it could help with this situation)

Is there anyone also having the same problem? And can anyone please let me know how to recover the file?
I use MacOS Mojave 10.14.6
Thank you so much.

So you have an .aup3 file that won’t open. If you care to zip up the file, upload it to a public file sharing service such as dropbox or google drive, then post (or PM me) a link. I’ll take a look at it.