Audacity crash recording live audio second track

Hello, everybody…!
I am a newbie both on Linux and music recording, from Portugal.
I am trying to give some use to a Asus EeePC 901, 2Gb RAM, with CrunchBang Waldorf.
I have a USB M-Audio M-Track Plus audio interface and M-Audio audio monitors.
I am using Audacity 2.x

On another notebook with Windows 8.1 everything works fine.

  • On EeePC with Crunchbang using the computer internal mic i can record and play multiple tracks;
  • Using USB M-Audio M Track Plus I can record one track, but if I try to record a second track, Audacity crash and disappear. If I start it up again it asks if I want to recover the unsaved project.
  • For everything else I use both devices without issues: listen to music both from files or Internet.

I think it is not supposed to need a driver for the M-Audio device.
Is there an USB issue…? An M-Audio devices issue…?

Looking forward for any tip or similar shared informations…!
Thanks very much for your support

Are you overdubbing? You record the violin part and then go back and record the trumpet part and then go back and record the piano part, etc? The question seems to tell us you’re trying to record three and four different audio tracks at the same time.

When you tell us the Audacity version, use all three numbers.

Sometimes we can catch up quickly if you tell us the goal. “I want to record a string quartet by playing all the instruments myself.”

I am trying to give some use

We pay attention to all your words. “The computer isn’t powerful enough for anything else so I thought I would try Audacity.” Audio (and video) production software is very stressful for a computer. The machine can’t stop for a second and catch up. Everything happens in real time and that may be why it will not play one track in real time and record a second one.


Hi, thanks very much for the reply…!
I am usisng Audacity 2.0.1-1 (the latest synaptic gave me)
Yes I am doing what you called overdubbing.

When I first used a Notebook with Windows 8.1 I did record multitracks separately, each one at a time, with the M-Audio audio interface. EX: track 1 guitar, track 2 piano, track 3 flute. No problems.
Audacity used to play previous recorded tracks, and I could live record a new one along with the others.

With Asus EeePC 901 and CrunchBang Waldorf, I am trying to ro the same thing.
I can do that with the computer internal microphone. I just tap somewhere on the computer and I am able to record several rhythms in different tracks.
But using M-Audio device I can not. When I want to live record a second track along with a first one Audacity crash.

Thanks again for your support…!
Al the best

Asus EeePC:
Latest BIOS 2103
Intel Atom N270 1600 MHz
1st HDD SSD 4Gb
2nd HDD SSD 8Gb
(no sd card expanded)
Linux CrunchBang Waldorf

I just did a recording with guitar, tapping computer cover, and voice, in three different stereo tracks, each one at a time, using the twou tiny mics on the computer screen, with no problems. Well, the sound was terrible…
On final playback the fan went a little up but nothing crazy.
This make think that if it was possible to connect the M-Audio device to the computer MIC input it would be possible to work again with both devices with no issues.
Hope this help to figure out a problem between LINUX, AUDACITY, EeePC 901 and USB connection with M-AUDIO M-TRACK PLUS

Ensure that in the Transport menu, “Overdub” is enabled and “Software Playthrough” is disabled.

In the device toolbar, try setting the recording input and playback output setting to the hardware devices that you are using (the “hw” options). Note that for the “hw” options to work there must be no other audio application using the selected device (this includes Flash or other media players in your web browser).

Hi…! No words to thank you for your support.

Overdub was enable, and Playthrough was disable.
BUT… now, I don’t know why, Audacity doen’s crash anymore and started to overdubbing with USB M-Audio connection with terrible noises and interruptions during recording.

I repeat that this happens with the USB M-Audio connection.

I will try to connect the M-Audio through computer MIC input and see how overdubbing recording goes.

For now I wil send you screenshots of may Audacity configurations, as I might be doing something stupid…!

In “Preferences > Quality”, try changing the “Default sample format” to “32 bit float”.
Does that make any difference (better or worse).

I presume that you have tried rebooting the computer?

Also try setting the buffer higher in Recording Preferences.

Have you tried a more lightweight distribution? Crunchbang says it is nimble but it clearly is not optimised for low powered machines. Experience can vary quite a lot on eeePC’s. Did it come with Crunchbang?