Audacity crash on startup on OS 10.6

I can’t get Audacity 2.03 or 2.02 to startup without crashing, either straight away or when I try and open an mp3 file or drag and drop the file to the Audacity window.

I tried replacing the audacity.cfg file with the suggested one disabling the audio thingos but that didn’t help.

Crash report attached with the first bit copied below, and thanks in anticipation.


Process: Audacity [417]
Path: /Applications/Audacity/Audacity
Identifier: net.sourceforge.audacity
Version: (
Code Type: X86 (Native)
Parent Process: sh [414]

Date/Time: 2013-03-12 18:38:00.142 +1100
OS Version: Mac OS X 10.6.8 (10K549)
Report Version: 6

Interval Since Last Report: -1400702 sec
Per-App Interval Since Last Report: 117 sec
Per-App Crashes Since Last Report: 5
Anonymous UUID: 39EE8BB0-39DE-4B25-BC44-6EEF39301ED5

Exception Codes: KERN_INVALID_ADDRESS at 0x00000000176ffff8
Crashed Thread: 0 Dispatch queue:

Thread 0 Crashed: Dispatch queue:
0 libSystem.B.dylib 0xffff0f1a __memcpy + 1914
1 0x90892404 CArray::ReplaceElements(long, long, long, void const*) + 132
2 0x908b7052 CUnicodeTextension::UnicodeReplaceRange(long, long, TReplaceParams const&, unsigned char, unsigned char) + 1904
3 0x908b7509 CUnicodeTextension::ReplaceRange(long, long, TReplaceParams const&, unsigned char, unsigned char) + 101

…continues in attached file…
Crash report.txt (41.7 KB)

Your crash report appears to be one from when you tried to open Audacity by double-clicking an AUP file or drag-and-drop and MP3. Could you post a crash report for when you simply double-click the Audacity application? That might make things clearer.
– Bill

Also when you do import the MP3, where exactly is that file located (please right-click or CONTROL-click the file > Get Info and look at “where”).

Is the file in a folder in the Dock? Does its name or the name of any folders it is in contain symbols or accented (non-English) characters?

How exactly are you launching Audacity when you try to launch it without opening the file? Where is Audacity located?

Thanks for your patience.


Hi folks,

Thanks for the help. I think I’m getting somewhere. I reverted from 2.03 to 2.02 which is not crashing on startup. It only crashes when some mp3s are either drag and dropped or I try to open them. Crash reports for both attached.

I have a theory. These mp3s were using a cheap sound system that records an mp3 on a USB stick as the cassette plays. My suspicion is that it doesn’t put in all the normal info (that’s my non-technical reference to all the invisible stuff in the file) and that Audacity doesn’t find all it wants. Even though the mp3s do play okay.

The third file #3 is one that came off the cheap cassette to USB system and then to trim off the silence I ran it through Quicktime and saved it in ‘original format’ which shows on the Mac as a Quicktime movie but in the info panel the kind is Quicktime movie but the codecs is MPEG layer 3.

Thanks to all for the good work!
#3-Drag and drop the .mov mp3 file.txt (31.9 KB)
#2-Crash on drag and drop.txt (31.9 KB)
#1-Crash on trying to open via Audacity open command.txt (41.8 KB)

The real name of MP3 is MPEG1 Layer 3. It was called MPEG before there was an MPEG2. It’s the sound channel for an early video format and that’s normal. Koz

OK, so Audacity does not crash when you start it by double-clicking its icon. It’s only when you try to import certain MP3 files.

Try converting those MP3 to AIF files using Max.

If Max crashes then we know for sure the problem is with the MP3. If Max converts them, then at least you’ll be able to import the files (as AIF) into Audacity.

– Bill


Was 2.0.3 crashing on startup when you just double-clicked the Audacity icon, or not? If it was so crashing, then it would be helpful to get 2.0.3 again, Audacity > Quit Audacity in 2.0.2, then double-click the Audacity icon for 2.0.3 and send us a crash report for that incident.

While the MP3 headers or metadata could be the problem, all your attached errors are also identical to errors seen when files crash due to their location, or due to accented characters in the file name or in the names of folders that file is in. As yet, we’ve never completely reproduced that problem, but it definitely exists. So please try to answer the questions I asked previously here .

If Max converts the AIFF files, a good test to try those AIFF files in Audacity would be to put them in the exact same folder that the MP3 files are in, then drag the AIFF’s into Audacity.

Another thing you could try would be to reboot the Mac. Occasionally, some kind of memory corruption can occur with Audacity on Mac and once it happens, it tends to cause import and export crashes that go away after reboot.