Audacity crash on opening opus file

Hi, when trying to import an opus file in Audacity 3.4, it crashes and exit.

Here is the crash report.
crash report.txt (314.2 KB)

I ASSUME there’s something wrong (or something unusual) with your opus file.

But I also assume you can play it with Windows Media Player?

Try converting it to WAV or FLAC with Kabuu Audio Converter. Sometimes when Audacity can’t open a file, a different decoder will work.

I don’t know how to interpret the crash log…

I’ve also never used opus but I found a file online and Audacity opened it.

1- Yes, it does work with Windows Media Player.

2- And it worked after I converted it to WAV.

Maybe the problem is on my specific hardware.

Audacity 3.4 is using the latest and greatest official Opus decoder and … it failed and asked FFmpeg to open the file instead. The latter has crashed.

Is it possible for you to share this file?

Yes, here is the file.

Also, exporting to opus works perfectly. Importing crashes Audacity.

The forum has converted it into the forum format :disappointed_relieved:

Can you please send a zip file?

I tried to, but I get this message when I select the zip file:
“Sorry, the file you are trying to upload is not authorized (authorized extensions: jpg, jpeg, png, gif, heic, heif, webp, mp3, wav, ogg, flac, opus, aup3, txt, ny, lof).”

This topic was automatically closed after 30 days. New replies are no longer allowed.