Audacity could not read its default theme

This problem has occurred both with 2.0.5 and svn 13081. Am building from source in a BLFS-7.4 environment, with --disable-ffmpeg (my ffmpeg version is too new, apparently). Linux kernel is 3.13.3. After the dialog box containing the error (subject line; also tells me to report the problem), audacity comes up but all controls are black. Apparently there is an issue with the contents of ThemeAsCeeCode.h? Searched forum for “default theme”, could not find postings re: my problem. Apologize in advance if I mis-searched. Many thanks,


This is a known issue with some dark themes (Desktop) and is listed in the Audacity release notes (Missing features - Audacity Support)

Audacity has experimental Theme support which is disabled by default. This has not been worked on for quite a while so I don’t know how well it will work, but it can be enabled by building with Theme support enabled in Experimental.h (search the file for #define EXPERIMENTAL_THEME_PREFS )

FWIW, (unmodified) Audacity displays fine on Debian (which has a dark theme by default).

You may be able to get ffmpeg working by specifying “local library” rather than “system library” for ffmpeg.

Found a bit of (old) documentation about theming Audacity:

I suspect the problem is that I have libpng 1.6.4. I have tried to use ImageCache.png files from the web, and they display without errors in SeaMonkey, but Audacity 2.0.5 rejects them.

I attempted to rebuild Audacity using an older libpng, but found I’d have to rebuild half my system, so that’s out.

Does anyone have an ImageCache file from a system using libpng 1.6.4 that they could send me? My e-mail address is .

Many Thanks,


Attempted to rebuild audacity 2.0.5 with xpms by

sed -i src/AllThemeResources.h -e ‘/XPMS_RETIRED/d’
sed -i images/ControlButtons.h -e ‘/CleanSpeech/d’
sed -i images/EditButtons.h -e ‘/LinkTracks/d’

Compiled and installed clean, started with no errors, but all buttons still appear black. Any ideas how to get xpms working, since pngs don’t seem to work on my system.

Thanks in advance,


Have you tried using a light theme for the OS?


I am not all that familiar with OS themes. I am not using a desktop environment like gnome or kde. I am using windowmaker as the window manager, and run everything else from the dock or from an xterm window. I am sure there is something that I am missing in doing it this way, although audacity 1.2.6 works fine in a very similar (but older) environment. Can you post a link to a light theme ImageCache.png file that I could try?

Thanks in advance,


The only pre-built themes I know of are and a number of them in Request: Skin .


I attempted to use

All got the same error dialog box:

Audacity could not load file:
Bad png format perhaps?

followed by the familiar error dialog box:

Audacity could not read its default theme.
Please report the problem.

This is Audacity 2.0.5 built with wxWidgets 2.8.12, libpng 1.6.9, gtk±2.24.20, gdk-pixbuf 2.28.2, glib 2.36.4.

Ken loads for me in Audacity HEAD on Ubuntu 13.10.

You may want to fix the typo. Audacity’s _data folder on Linux is called “.audacity-data” (without quotes).


For what it’s worth, my libpng version is 1.2.49 and gdk-pixbuf 2.28.1.

What happens if you open in an image editor?