Audacity closing with new recording

Hi there,

I have been using Audacity successfully for several years. Today, when I tried to record a new track, it completely closed. I re-opened and tried just listening to an already recorded file. It worked fine. I hit “record” and Audacity immediately closes. I have shut down/restarted, but always the same problem.

I have checked my microphone settings through my Mac and the mic is working/picking up my voice as usual. For reference, I am running Audacity 2.4.2 on an iMac , Ventura 13.2.1

Any help is much appreciated.

Did this issue start immediately after upgrading to macOS 13.2.1?

No – have been on that operating system for at least a year.

Has anything changed on your machine in the last few days?

You could try a “hard reset” of the Audacity preferences.
Go to ~/Library/Application Support/audacity and delete the file “audacity.cfg”. You will lose any custom settings, but this will reset Audacity to “factory defaults”

Hi Beth,

Fellow 2.4.2 user here. I’ve been holding off upgrading to OS Ventura because several users on here have reported issues running Audacity 2.4.2 after updating to OS13 (released in October '22).

Are you certain you’ve been recording into 2.4.2 on Ventura without any probs until the other day, or is it conceivable you had only used Audacity for editing since the update to OS13?

Thanks for your message. I’ve definitely recorded since the update. Is there something you know of that fixed this problem for others?

I’m really nervous to do that - it’s been several years since I’ve done all of my mastering settings - I don’t remember how I set everything up!!

For what it’s worth, I cannot reproduce this issue with Audacity 2.4.2, macOS 13.2.1 on both an intel iMac and an M1 Macbook. I start Audacity and record from the internal microphone.

Understood. Sadly no, I’ve nothing other than Bill’s suggestion to delete the config to reset to factory defaults, or of course to take the plunge and update to the latest version of Audacity.

Reading between the lines, it does seem that 2.4.2 is at best slightly iffy on Ventura. Since Bill found no issue recording with the built-in mic, perhaps the problem only surfaces with an external input.

So, I tried recording from the internal microphone, closes immediately.

I guess I will update Audacity and see what happens. It gives me a stomachache to try and figure out how to master everything again from scratch.

I went ahead and followed your directions for a hard reset. I deleted the audacity.cfg file and cleared it from the trash. I re-started Audacity, tried to record and it immediately crashed just like before.

I threw in the towel and updated to the Audacity 3 – thank you for trying to help!

This topic was automatically closed after 30 days. New replies are no longer allowed.