Audacity Clock too fast

I’m using Audacity 2.1.2 on Linux Mint 17.3 64bit on an Intel i5 4 core box.

I have noticed the timing of a recording shown in Audacity is considerably longer than the actual time that has flowed during that recording. A thirty minute recording will show over thirty three minutes according to Audacity.

I tried renaming the .audacity… folders to reset the system but this made no difference. I know I can speed up the recordings about 1.1 to compensate but it would be better if the recording timing agreed with real time in the first place!

Have I mucked up a setting somewhere or, is this a bug?

Audacity does not have a clock. It just uses sample rates. When recording it will request audio at a specific sample rate (by default 44100 samples per second) and it assumes that the audio data it receives has 44100 samples per second. Similarly on playback, it tells the audio system what the sample rate of the data is, then sends the data and it is up to the computer sound system to play it at the right speed.

Are you sure that a 30 minute recording is not showing 32:39.184 ?
(yes that is a very specific number - there’s a reason for that)

Also, what exactly are you recording? If you’re recording playback of a file, either locally or streamed from somewhere, that is another reason for possible problems.


I’m currently streaming through the BBC website a programme from BBC Radio 4 Extra. (

I have Pulse Audio set to record from the Monitor of the computer’s audio output.

Can I assume the sampling rate of the downloaded programme is upsetting the rate at which Audacity is sampling? And if so, could a change of the sampling rate on Audacity correct this?

Currently I’m using a Stop Watch to time the length of the recording, comparing it to the Audacity recording length and then calculating any multiplication factor needed to correct the speed.

Thanks for your help in this.

The speed difference sounds about right for the difference between 44100 Hz sample rate and 48000 Hz sample rate.
What is the sample rate of the track that you have recorded? (look in the panel on the left end of the track).
If it is 44100, then try changing it to 48000 by using the “Rate” options in the track’s drop down menu (