Audacity changes Windows volume balance when launched

I’ve noticed that this has been a recurring issue for many years now so i apologize for bringing it up again, but my hearing is better in my right ear than my left and use the Windows volume balance to level it out, but when Audacity is launched it is reset.
I use Windows 7 64bit, i’ve tried Audacity versions 2.1.1 and 2.1.0.

Thank you in advance for any help.

There is no known fix. :frowning:

I presume you have read the other posts about it already, but if not, try choosing a different host in Audacity Device Toolbar, or go to the web site of your computer manufacturer and see if there is a later audio driver for your computer model.

If that does not help you can open Windows Device Manager and see if there is a previous set of drivers you can roll back to.

Otherwise try going back to Audacity 2.0.2:


Hey Gale, i bet you rolled your eyes when you saw this issue again :stuck_out_tongue:.
Your suggestion worked, chosing Windows DirectSound didn’t help but WASAPI did, my balance setting is maintained.

I don’t know if there are disadvantages to using this setting, i’ll see what it’s like later if i decide to record, i’ll try version 2.0.2 if i have any problems.

Thanks for such a quick response.

OK, WASAPI for physical inputs like mic and line-in was only introduced in Audacity 2.1.0 and later. It was just my hunch WASAPI might help but no-one until now had said it fixed the problem.

There are quite a number of issues that have been reported with WASAPI host, though it will vary from machine to machine. See and scroll down a little.

Changes for Audacity 2.0.3 probably have caused this issue (at least for MME or Windows DirectSound) but for most people the changes were beneficial, ensuring that the Audacity volume sliders and Windows volume sliders moved in parallel with each other. So if you did go back to 2.0.2 you may or may not have other volume issues.


Bit of an update, when i try to record it asks me to select a recording device even though one is already selected or to choose a project rate, doing either lets me record, then when trying to playback it asks to select a playback device or rate, selecting one counteracts the other so i couldn’t for example playback and record at the same time.
I went back to version 2.0.2 and that’s resolved everything, volume balance sticks even on MME and there are no problems with my devices.

Random suggestion but i’m sure it would have been in the program already if it was possible, an option in preferences for Windows audio balance, if a user has this issue of the balance being reset we could tell Audacity what our balance is and it can set it to what it already is when launched. It’s obviously not fixing the problem but it’s a way around it.

Do you mean that you saw “Error opening sound device” messages?

You may see that error, per the link I posted. It may be soluble by making the settings in Windows Sound that are suggested in the link.

Or it may be soluble by updating your sound device drivers as described, if they are not already the latest ones intended for your computer model.

That assumes though that Audacity could directly control any device’s audio balance in Windows (beyond merely resetting it to zero due to a bug). It would be a significant new feature.

It might perhaps be a better idea (for which we already have experimental code) to set pan when creating a new track.