Audacity changes pitch of recorded MIDI file.

Greetings, - New member just now. I’m unable to find anything on the Internet about my problem. Nothing in a quick search on this forum. I’m using Ubuntu 14.04 with Audacity 2.0.5 installed with apt-get. The problem: I have a MIDI file that I play back using VLC. (VLC has the fluid synth plugin). Audacity records it ok and converts to mP3 just fine. But, when I play the mP3 file, the pitch is lower by about 1.5 semitones compared with the MIDI file pitch. Why is this happening ? And other than using “Effects/pitch change”, to get the pitch back to where it should be, what can be done about this ? -


This is quite common on Linux if you record using pulse, which should handle resampling properly but sometimes doesn’t. Please tell us exactly what recording input you are choosing in Audacity to record MIDI playback.

You “may” be able to prevent the problem happening by changing the project rate bottom left of Audacity. If it is set to 48000 Hz, change it to 44100 Hz, or if it is set to 44100 Hz, change it to 48000 Hz.

The better fix is to use Effect > Change Speed…, because I assume your recording is also too long. If the problem is a 44100 Hz/48000 Hz mismatch that you still receive even when changing the project rate, you can simply open the Audio Track Dropdown Menu and use “Set Rate” to change the rate to 48000 Hz.

If you regularly convert MIDI to audio, you could try Timidity:

sudo apt-get install timidity


As you have the fluid synth plugin for VLC, you don’t need to “record” the MIDI file. VLC can render it directly to a WAV file (or any other supported format). Select “Convert/Save” from the “Media” menu.

Do you also have “fluid-soundfont-gm” installed? It is a high quality “soundfont” that many MIDI players (including VLC) can use. After installing, you would need to configure VLC to use it: “Tools > Preferences” → Select “All” → “Input/Codecs > Audio Codecs > Fluidsynth” → Click the the “Browse” button and locate “FluidR3_GM.sf2”. On my machine it is installed at:

Just now getting back to this project. Thanks for the help ! Steve, I did what you suggested in VLC; convert/save. Didn’t see WAV but the conversion to mP3 worked well. I’ll check out what’s possible in Audacity later when I can find the time. Yes, I have to use Pulse Audio with this PC. Otherwise I can’t get stereo mix. In Linux/Ubuntu it’s pavcontrol (like an audio server I guess).

Best Regards,

They call it “Audio - CD” (yes I think that is a bit confusing :wink:)
I presume what they mean is “CD quality” (16-bit / 44100 Hz).