Audacity can't use any audio devices


I recently purchased a new computer (or rather, built a new computer :smiley: ) and went about reinstalling all my audio equipment. One of these is Audacity. However, whenever I attempt to record in Audacity, it hangs for about a minute and then tells me that there was an error opening the sound device. It does this for every sound device that isn’t integrated into the motherboard (running an MSi motherboard with integrated Realtek audio). I have up-to-date drivers installed for the Audiobox 44VSL and the Virtual Audio Cable. Both are selectable from the drop-down devices list.

I am running Windows 7 x64, v. 2.0.3.

Thanks for your help!

Thanks for helping with some of the questions recently :slight_smile:

Have you tried everything at ?

What host are you choosing in Device Toolbar ? MME is the most compatible.

Have you tried Transport > Rescan Audio Devices?

Does the error occur even recording a single track into an empty project? Or are you recording overdubs?


I have tried everything in the manual and some googles (otherwise I wouldn’t be posting :stuck_out_tongue: ). Rescan does nothing as the devices are in the list and selectable, they just hang Audacity and then error when attempted to use. I tried both hosts, DirectSound crashed Audacity so I switched back to MME. The error occurs regardless of track material. I have noticed in my snooping in the device settings that it doesn’t seem any of the devices are working at all, which is strange because they’re all configurable and I’ve updated all the drivers (multiple times, in fact, in case of a botched install) and such. Perhaps I should not post here and move to a Windows forum…but you’re probably more knowledgeable on audio stuffs :slight_smile:

So…any ideas?

You’re very welcome!

DirectSound should not be crashing Audacity with Firebox or Virtual Audio Cable (VAC).

Where do you see an indication that the devices are not working?

Have you tried setting Firepod or VAC as default recording device in Windows Sound, then recording with Windows Sound Recorder or some other audio program? What happens then?

Let’s see what other recording programs do.


The indications were that the volume meters for the devices in sound manager were blank, even when I was causing the clipping LEDs to go off on the Audiobox (also, I should note that the box is USB, not FireWire - it has no such capabilities). Also, the Audiobox VSL (it controls the DSP on the Audiobox) was not reading any audio either, nor was it outputting anything on speaker pass-through. Sound Recorder just outputs silence. For the record, I know it’s not the box itself because I installed the whole shebang on a friend’s laptop for testing purposes and it all works fine.


It just started working for no reason.

Well, thanks for your help… :confused: