Audacity Broken in Mint 19.1 Cinnamon - SOLVED

Recently did a full upgrade PC and OS in Linux Mint to version 19.1 Cinnamon (Unbuntu 18.04 Bionic) The Unbuntu/Mint PPA for 2.2.2 is busted when using integrated MB sound. Audacious and media Player work fine. Symptoms are periodic gaps in record, high distortion and messed up speed, playback fast, and lock ups. Old SoundBlaster E-MU 0202-USB works fine. I believe it has to do with 7.1 sound chip set on ASUS Rog Strix B-450F Mother Board.

I’m not a programmer just a user. Linux since 1994.

Maybe a set of drivers for the MB would help?

System: Host: w7rh-System-Product-Name Kernel: 4.15.0-43-generic x86_64 bits: 64 compiler: gcc
v: 7.3.0 Desktop: Cinnamon 4.0.9 wm: muffin dm: LightDM Distro: Linux Mint 19.1 Tessa
base: Ubuntu 18.04 bionic
Machine: Type: Desktop Mobo: ASUSTeK model: ROG STRIX B450-F GAMING v: Rev 1.xx serial:
UEFI: American Megatrends v: 0504 date: 07/09/2018
Battery: Device-1: hidpp_battery_0 model: Logitech Wireless Mouse serial: charge: 55%
status: Discharging
CPU: Topology: 8-Core model: AMD Ryzen 7 1700X bits: 64 type: MT MCP arch: Zen rev: 1
L2 cache: 4096 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 108584
Speed: 2978 MHz max: 3400 MHz Core speeds (MHz): 1: 3258 2: 2805 3: 3235 4: 2851
5: 2817 6: 3164 7: 2880 8: 2814 9: 3467 10: 3442 11: 2857 12: 2989 13: 2888 14: 2821
15: 2920 16: 3308
Graphics: Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: driver: nvidia v: 390.77
bus ID: 08:00.0 chip ID: 10de:1c82
Display: x11 server: X.Org 1.19.6 driver: nvidia
resolution: 1680x1050~60Hz, 1680x1050~60Hz
OpenGL: renderer: GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 390.77
direct render: Yes
Audio: Device-1: NVIDIA GP107GL High Definition Audio vendor: driver: snd_hda_intel
v: kernel bus ID: 08:00.1 chip ID: 10de:0fb9
Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus ID: 0a:00.3 chip ID: 1022:1457
Device-3: Microsoft LifeCam HD-5000 type: USB driver: snd-usb-audio,uvcvideo
bus ID: 1-1:7 chip ID: 045e:076d
Device-4: Creative E-Mu 0202 type: USB driver: snd-usb-audio bus ID: 3-3:5
chip ID: 041e:3f02
Sound Server: ALSA v: k4.15.0-43-generic
Network: Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: 5.4.0-k port: e000
bus ID: 03:00.0 chip ID: 8086:1539
IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac:
Drives: Local Storage: total: 1.36 TiB used: 193.38 GiB (13.8%)
ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB
speed: 6.0 Gb/s serial:
ID-2: /dev/sdb vendor: Western Digital model: WD1003FZEX-00MK2A0 size: 931.51 GiB
speed: 6.0 Gb/s serial:
Partition: ID-1: / size: 456.98 GiB used: 23.43 GiB (5.1%) fs: ext4 dev: /dev/sda2
ID-2: /home size: 915.89 GiB used: 169.95 GiB (18.6%) fs: ext4 dev: /dev/sdb1
Sensors: System Temperatures: cpu: 39.8 C mobo: N/A gpu: nvidia temp: 32 C
Fan Speeds (RPM): cpu: 0 gpu: nvidia fan: 30%
Repos: No active apt repos in: /etc/apt/sources.list
Active apt repos in: /etc/apt/sources.list.d/google-earth-pro.list
1: deb http: // stable main
Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
1: deb http: // tessa main upstream import backport
2: deb http: // bionic main restricted universe multiverse
3: deb http: // bionic-updates main restricted universe multiverse
4: deb http: // bionic-backports main restricted universe multiverse
5: deb http: // bionic-security main restricted universe multiverse
6: deb http: // bionic partner
Active apt repos in: /etc/apt/sources.list.d/skype-stable.list
1: deb [arch=amd64] https: // stable main
Active apt repos in: /etc/apt/sources.list.d/ubuntuhandbook1-audacity-bionic.list
1: deb http: // bionic main
2: deb-src http: // bionic main
Info: Processes: 337 Uptime: 14d 8m Memory: 31.40 GiB used: 3.54 GiB (11.3%) Init: systemd
v: 237 runlevel: 5 Compilers: gcc: 7.3.0 alt: 7 Client: Unknown python3.6 client
inxi: 3.0.27

Have you tried the official Ubuntu repository version?

Note that PPAs are not recommended unless you have a very good reason not to use the official repositories, AND you are able to fix problems that may occur when using PPA versions of software.

Original Install was directly from Unbuntu. The PPA works exactly the same. :unamused: :unamused:

So is this the version of Audacity that you have:

Yes the version is 2.2.1 from Unbuntu/Mint library.

I’ve looked on Google for problems with the NVidia High Definition Audio on Linux, and found (as no doubt you did), that quite a few people have had problems with this device. In some cases, after lots of messing around, they appear to have resolved the issues, but I don’t see an easy fix.

So do you really need to fix the NVidia issues, or can you just use the SB? (I’d be very tempted to stick with what works).

Thanks for the reply. Like you I have looked across the net. Everything worked here until I upgraded PC. LOL Sometimes that is the way Linux is. Once set up stable as a rock but drivers are hard to find and without source code I can’t build one for Linux.

Seems that most of the suggestions don’t resolve the issue. I went through probably 50 command line fixes, installs and removals. All related to past Kernels. Seems they may have carried through the same bug. Audacity loves the EMU…Signal to noise ratio and dynamic range are far better than on board audio anyway. I’ll take a look at the stored configuration file.

I wonder why the other programs Audacious and VLC work fine. Perhaps the detected device script installs the wrong driver. Who needs 7.1 audio anyway? I’m an analog guy and 2.1 suits me fine.

if I find something I’ll post it!

Bob, W7RH

Perhaps it’s because they don’t use the recording side of the device.

I’ve also got an old SB / EMU 10k1 chip sound card tucked away somewhere. I used to use it on my old Windows 98 machine with the kX Proect drivers. It was an amazingly good sound card in its day, and still way better than most on-board sound cards (proof that specifications often tell lies :wink:)

I found it! Gnome Alsa mixer has a false reading on display. Master not tagged a muted by was. thus, I was selecting the wrong driver. You have to move the slider to correct!
Also, there are is new drivers available but not in Linux.

On my system Audacity is working with the following parameters:
Line In HD-Audio Generic Analog (hw;2,0)
Speakers HD-Audio Generic Analog (hw;2,0)
problem solved. :smiley:
Bob, W7RH