Audacity big Effects menu: (bug) and quick fix

Hey Guys,

this is something that has been around Audacity for many versions now and bothered me some times and eventually I registered to post this:

I use Audacity 2.1.0 on Win7.

As already known the Effects menu gets really big when there are many Plugins installed.
When I use it I get the “bug” that after long-clicking the down-Button once I can hover it to scroll really quickly.
This doesn’t work for the up-Button and stays until I restart Audacity (Even after re-opening the menu).

This wouldnt be a big problem and actually a nice feature if it would also work for the up-Button :wink:

The Quick-fix:
To make this better useable besides creating Categories and a shorter menu I would suggest the behaviour of many other programs (e.g. Firefox):
Enable Mouse-Wheel-Scrolling

I think this would be easy to do (But I don’t know if this isn’t a problem of GTK+).

Cheers and thanks for the great work,


To make this better useable besides creating Categories…

Creating categories isn’t the fix. That makes multiple instances of the same effect (which happens all the time) a nightmare. The fix is the ability to create a custom list of effects you use a lot and/or the ability to assign hot-keys to effects.


In Audacity 2.1.0 you can categorise effects according to a number of criteria (such as grouping VSTs separate from LADSPA separate from Nyquist…)

Also, on Windows you can jump down to the next plugin that starts with a particular letter by entering the effect menu and typing that letter.

Thanks for the information.

As I’m not yet a user that knows exactly what filter he wants but rather searches for nice stuff I still think the scrolling feature would be really nice to have


There may well be changes to such things as mouse wheel control after we update to wxWidgets 3.x. There is currently no schedule for that update, but it’s just a matter of time.

Which button are you talking about - the up arrow at the top of the Effect Menu and the down arrow at the bottom? Those should work if you hold either button down until you want to stop scrolling. Those actions don’t cycle through from top to bottom or bottom to top. If you want that, use UP arrow or DOWN arrow on the keyboard.


Hey guys,

I just discovered the source of the “bug”.

My screen is just as high that the last visible option of the menu isn’t displayed completely.
When hovering it, the UI detects that it isn’t completely on-screen and scrolls down until it is.
As during scrolling the elements will always align to the top edge, there will always be one element which isn’t completely visible.
So as long as I move my mouse inside the area of the partially-hidden option it will scroll down with each mouse event.

But thanks for the hint with the up and down arrow.
I will probably use them until the scrolling feature is available as they are a lot faster than pressing the buttons on screen.


Another minor thing, maybe someone could bring this to the translation guys:

The german translation of the new Noise Reduction-feature says “Vermindern” (Reduce) for both options instead of sth. like “Isolieren” (Residue) for the second as before.

Thanks for your great work!

Thanks. It has been noticed, and we also know that the other controls in Noise Reduction are not translated (which is a bug in the Audacity code, not a translators error).