Audacity begins recording, then flatlines...

Can anyone tell me what’s going wrong? I’ve been using Audacity 2.0.6 on Windows 10. I have been working with this version of Audacity for about six months, and while I have had a few other issues with it, I have not experienced this before. When I try to record, which I have done many times successfully in the past, it begins to record for approximately six seconds, and then flatlines. I cannot hear anything when I try to play back, and nothing shows up in the track after initially showing a wave pattern. I have tried rebooting. I have tried trying to get the system to recognize the microphone. Nothing seems to work. The time that it seems to record is always the same - six seconds, and then it flatlines. If I try to stop the recording process before the six seconds, it will also flatline. Does anyone have any suggestions? Any assistance will be greatly appreciated.

Try opening Audacity and immediately save a Project on the desktop. Then try to make a sound recording in addition to that. Just press Record. If that works, then you or Audacity don’t have permission to record sound to the default drive location that Audacity picked when you installed it.

I don’t know how to fix that. I’m not a Windows elf.


Also, it can happen that cleanup applications will randomly delete your Audacity temp files when they get round to it, or anti-virus apps will scan the Audacity temp folder and lock it while they are scanning. Even if they don’t lock the temp folder, the scanning can slow up the writing of each little recording file and cause audible glitches in the recording.

You can change the location of the Audacity temp folder at Edit > Preferences… then the “Directories” section.


Thank you, Kozikowski and Gale Andrews for your responses…I’ve tried working with my program some more, which I’ve used successfully for more than six months already, and this is what I’ve found. I don’t know if it is important or not, but I can open previously recorded pieces that I successfully recorded during this time, and I can record or dub additional tracks to this, but when I try to begin recording a brand new song, that is when the waves appear for six seconds and then disappear again. I’m wondering if this is some sort of setting that may have gotten corrupted or changed? The old tracks sound fine. It’s just anything new that I try to record will not function properly, and I am nowhere near my limit of 40 hours of total recording time. I’m probably closer to ten hours of recorded music. If anyone has any thoughts on what may be causing this, it would be greatly appreciated.

PS - I did try your suggestion, Kozikowski, but as soon as either 6 seconds is up, or I try to stop the program to save anything that I have recorded, the waves flatline.

Gale, I also tried your suggestion regarding the temporary files…nothing changed. I still cannot record for more than 6 seconds at a time, and then everything disappears.

So where exactly is your Audacity temp folder now? If strange things are happening then your temp folder is best placed in your own user permanent user space, such as in Documents or Music where you should have permission to write, and without “temp” anywhere in the folder name.

Are the old pieces you open Audacity projects or imported files? Importing a file or making a recording uses the exact same temporary folder, whereas opening or editing a saved project does not use temporary space at all.

When you import, a large number of short files are produced more or less at the same time. When you record, Audacity produces a short file or pair of files every few seconds. It’s quite possible a cleanup or anti-virus app would target short files appearing every six seconds as ripe for cleanup or as “suspicious”. If your Audacity temporary folder was for example set as “C:\Users<your user name>\Music\Audacity recordings”, cleanup or anti-virus apps will be much less likely to interfere.

If you have Norton, that is very likely the cause of your problem. To solve it, turn off its “Windows Temporary File Cleaner” or set it to manual operation, then you won’t have to change the Audacity temporary directory.

If it is really Audacity settings corruption then I suggest you install the current Audacity 2.1.1 from into the same folder where 2.0.6 is installed. In the “Select Additional Tasks” screen in the installer, put a checkmark (tick) in the “Reset Preferences” box. Complete the installation. On launching Audacity, confirm that you do want to reset preferences.

Note that this reset of preferences will set the Audacity temporary folder back to having “temp” in its name. So if Norton or some other app is interfering and you can’t control that app, you may still need to change the temp folder to not have “temp” in its name, or save a project (File > Save Project As…) before you start recording.