Audacity automatically inserts silence before track[SOLVED]

Hi there, I’m trying to create a track that loops continuously in an external program (specifically for a ringtone) but whenever I export my finished track, Audacity automatically inserts 0.050 seconds worth of silence at the beginning of my exported track. Does anyone know why/how it does that and if I can disable that feature? Thanks!

It’s an MP3, right? Never do production in MP3. MP3 is a video format (MPEG-1, Layer 3) and likes to travel in even video frames whether or not your show lines up that way. There was one timeline setting you can change that will force your edits to line up so you don’t have to worry about it later – and I’m still looking for it.

I think you can also use compressed sound formats other than MP3. MP3 has been around for a very long time and has baggage.

There was yet a third option. Depending on how much room you have, produce a very long track with the loops built in. This is an old DVD trick. The opening animation seems to be looping cleanly and gracefully every ten seconds, when actually it’s a video of loops and the whole collection loops every three minutes, but nobody ever sticks around that long.


OK, I understand what you’re saying Koz, and I know how to do what you are suggesting. That’s not the issue. The issue is that when there is NO space before the track in my audacity project and I export it Audacity automatically inserts 0.050 seconds worth of silence at the beginning. That’s what I’m trying to fix.

I’ve tried exporting my clip as a .wav file, and there’s no silence before hand. So it might be a problem with either the way Audacity exports mp3’s or it might be a problem with the LAME mp3 encoder. Are there any other suggested encoders that I could test to see if the problem persists with them as well?

The gap at the start is a problem with the MP3 format specification. See for a technical explanation.

There is not much you can do if you insist on using MP3 unless you play the loop in an application that tries to support “gapless MP3 playback” and/or if you try to cut out the silence using a direct MP3 editor . See the above LAME tech-FAQ for why even cutting and pasting at MP3 frames may not work cleanly.


Ah, so it is the encoder then. Oh well. At least now I know why audacity was doing that.

Tanks for the help guys. Topic can be closed now.