Audacity Already Running Error

Okay, I’ve already seen several conversations on this topic and followed all the fixes in each with no luck. So, I’m posting my own new topic. I’ve been running 2.0.6 with Yosemite and have had no problems. Yesterday I got a pop-up that Audacity had quit unexpectedly but I wasn’t using it at the time so I didn’t pay much attention. When I went to open it last night I got the already running error and it froze. Had to force quit. Since then I have…

Uninstalled, removed cfg files, restarted, re-installed and re-opened in the applications file not from dmg. Same result. Repeated the process and have uninstalled and reinstalled at least four times now. Done full shut down as opposed to just restart. I’ve checked top in utilities and it’s not running there. This was running perfectly for the last three weeks (when I initially downloaded it) and I need this. I do voice over work and travel so this is my portable studio.

Like I said, the other fixes I’ve read here have all been tried to no avail. So either I’m doing something wrong or this problem is a new twist. I suspect the former. In any case…please help.

I do voice over work and travel so this is my portable studio.

Can you roll the machine back pre-Yosemite? Audacity 2.0.6 does not support Yosemite. Can you run an earlier Mac OS from a separate FireWire drive? I’ve done that. It records that way, too.

Delete Audacity. Go > Applications > drag the Audacity folder to the trash. Restart.

Apple > Force Quit (but don’t actually do it). Do you see Audacity in that list? I got burned once when I kept an older Audacity application in its own backup folder separate from Applications, but OS-X went out and found it anyway—and tried to run it.

There are two Startup Applications settings. One is fairly normal, but the other is very exotic. Looking.


Apple > System Preferences > Users & Groups > You > Login Items.

How many users are there in that list? It should be just you and Guest User which is turned off.


Depending on the history of your machine, some of these may apply.


This is the better method - worth trying.

In Finder, Choose Go > Go to Folder and type:

~/Library/Application Support/audacity/

Open audacity.cfg if it exists, select all the text and delete it.

If audacity.cfg does not exist, open a new file in TextEdit.

Then type the following at the top of the file:


Save as audacity.cfg and restart Audacity.


How does that solve the problem of rogue Audacity automatically launching on startup?

You mean NewPrefsInitialized=1 ? It has been said to fix “already running” once before, after all manner of permissions and integrity checks achieved nothing.

If Audacity is not listed in top or Activity Monitor, one must assume it isn’t running until user tries to launch it.