Audacity 3.5.1 - Extreme Slow Down with Almost Every Operation I Attempt

I currently have Windows 10, and I recently upgraded my previous version of Audacity to version 3.5.1 and for almost a week, everything was fine, but gradually the longer the project the slower it became. Until a few days ago, I began working with a 45-minute-long voices-only project, recorded in mono, with only one clip. Everything was fine and working well until I started cutting, copying, and pasting lots of large audio selections within the single clip. Now, for some unknown reason, it takes an exceptionally long time for Audacity to process any of those operations. Almost everything I do from copying and pasting, to simply saving the project file will cause Audacity to stop responding for a long time, sometimes so long I have little or no choice other than to close the program.

Now it doesn’t matter how long the project is, it’s almost non-responsive. For example, I recorded a 6-minute-long segment of a YouTube video (audio only via the Stereo Mix (RealTek(R) Audio) recording device) and saved it as a project. I selected a 0.604 part of the overall clip and tried to paste it into the same clip, and it didn’t respond for 17 minutes before it finally completed the pasting process, then when I saved the project, it took Audacity 12 minutes to save.

I realize that it could be my system, but I’m not experiencing any slowness or non-responsiveness on any other application or operation.

Has anyone else experienced a slow-down such as this recently? I know with earlier versions this problem existed, but was apparently fixed, I thought. This is the very first time I’ve experienced this in previous versions of Audacity since its creation. I’ve been extremely satisfied and happy with Audacity and I still am, but I need some help. I’ve run every conceivable thing to examine and improve system performance, but so far it hasn’t affected the issues I’m having with the latest Audacity update.

Thanks in advance for any help or suggestions that might help.

Socrates

1 Like

You might try backing out to Audacity 3.4.2. The 3.5 versions have not settled down yet.

Koz

I took your advice and uninstalled Audacity 3.5.1 and re-installed Audacity 3.4.2, but I’m still experiencing the exact same issue. When I cut or copy an audio segment into the same track, and paste it into another part of the same track, from the time I select the destination and then paste, it takes over 15 minutes to finally appear at its destination. It may be the project itself that’s causing the problem, but I have worked on longer projects in the past (2012) and never experienced any slowness.

I literally recorded an audio track less than a minute long in which I merely said, “I am going home,” in Audacity 3.4.2. I saved the project and then copied the word, “home,” and tried to paste it into the track between my words, " am" and “going,” and that was over 30 minutes ago, and Audacity 3.4.2 is still not responding. This is crazy. And, as you know, this is after having the same experience with the latest version of Audacity 3.5.1. I used 3.4.2 during its entire existance and never had any issues at all until now. And I know it’s not my system. All other apps work as expected with no problems.

Thanks for trying. I appreciate it.

Socrates

I’m having the same issue - I use the program to transfer vinyl to the computer and it’s been pretty seamless until now. I believe this is the first time I’ve used the latest version of Audacity and I noticed even during recording that the live scrolling screen wasn’t keeping up with the music being played…figured it was something that I had inadvertently done. But once I started editing, everything was slow. I also saw a couple of errors that have never occurred before. There are whole sections where the recording just dropped out for no reason. Not reliable at all, and not happy having to try and re-record things with fingers crossed. Hope there’s another update soon, because the software is pretty much useless as it stands now.

I just started having this issue today, and I use the most recent Audacity version. It was a long project that I was working on (about 45 minutes of un-edited audio, edited down to around 25 minutes or so). I was almost done with the project, and when I saved it, it froze and stayed that way for 10 plus minutes! I tried to copy the AUP or project file and paste it in a different pathway or to my desktop, with no luck. IT was just stuck.

I also think what made it worse is when I shut down my computer after it froze… This is getting out of hand. And this is the first time in a few years of me ever using Audacity, that I’ve had such a major problem like this.

So it turns out my files or the AUP.3/Audacity project was corrupted. I could not open it because Audacity kept “Not Responding” basically. But I did some digging and was able to open my corrupted file and make it work like new.

There is another forum post regarding opening or recovering corrupted files. Here:

I just followed the instructions when opening the CMD black screen and typed what was needed, per the instructions. Keep in mind to recover any corrupted Audacity projects, you need to first install and Unzip the “Audacity Project Tools” from GitHub. I am not computer savvy, but If I can do it, anyone can do it.

Also, after the corrupted file was recovered, I was able to open it in audacity, then export the file as a WAV. file. Then I opened the exported WAV file in a new Audacity project. And wahlaa! It works MUCH BETTER, now with no freezes or crashes.

Accumulated “Undo” information as well as “smart clips” are capable of bringing a project to it’ knees. This can sometimes be corrected by creating a new project by following these steps:

  1. Ctrl+A
  2. Ctrl+C
  3. Ctrl+N
  4. Ctrl+V

Doesn’t that mean there is no more UNDO after you do that? You can only back up your edits to this exact time and no earlier?

Koz

I believe YES, YES, and YES. :grinning:

My files didn’t appear to be corrupted, as I was able to open them but the response time for moving around the file or doing any operation was incredibly slow. I ended up going back to version 3.5.0 and 2 of the 3 files responded to that version much better - very strange that they either all didn’t or did work. Anyway, I re-recorded the material using 3.5.0 and everything appears to be working now - no dropped audio and the screen activity appears to be normal.

Precisely why I stopped installing the newer updates, and stick with 3.4.1 or 4.2, as those updates have had bug issues that messed with my system.