Audacity 3.5.1 Bug Report - Crashing with "Internal Error"

I have been running Audacity 3.5.1 on Windows 10 since it was released.:disappointed:

Every other recording, I have been experiencing the same bug, where the recording abruptly terminates only a few (~3) minutes in. I tried closing the files, running CHKDSK (no disk errors found), and verifying that there were several GB free on the disk (NTFS on external SSD).

Then I try to restart Audacity and get an “Internal error at ProjectWindows.cpp line 75” on every project file (.AUP3) I try to open! In the past, I have rebooted my computer to get everything working again. This time, I tried to uninstall and even delete v3.5.1–repeatedly getting frustrating “application running” and “file open” errors. Using Task Manager, I identified an Audacity Error process still running. I killed it and managed to uninstall and delete v3.5.1. Phew!

I have re-installed v3.4.2–don’t use Cloud recording anyway. For now, I’ll stick with that version. But this and other bugs experienced with v3.5.1 are seriously making me reconsider Audacity. As I’m only trying to record simple MP3’s, for my needs the interface is quite overwhelming and the project files enormous. There are too many steps needed to export the MP3 I need.