Audacity 3.2 not installing

I had version 3.1.3 and Audacity prompted me to update to the latest 3.2. I accepted but when it finishde the update it would launch but not run. I tried unistalling and reinstalling it with a fresh download but still it doesn’t seem to work. I sent the log through the automated feedback window that popped up (instead of the application itself) and attached is also a copy. How can I install Audacity now?

I noticed that in the log file it says “Operating system: Windows NT” I am actually running Windows 10 fully up to date (updated a couple of days ago.

Also, where do I download the previous version (3.1.3.) from? There are plenty of pages on the Wiki about the releases notes but no download links.

On a separate note, when it will finally run correctly, how do I get the most recent opened files still opening from the file menu or at least find which were the latest files I worked on and their location?

Please see attached log file.

Thank you as always! :slight_smile:
Audacity Log.txt (70.4 KB)

Also as you can see from that attached screenshot, now it still shows the application in the Windows start menu but (because I have uninstalled it) it does not appear in the programs available to uninstall.