Audacity 3.0.4 new and old tracks freeze when I press Record button

While 3.0.4 has solved my issues with extreme slowness and (Not Responding), for some reason now I cannot record anything new.
Whether I am in an existing project or a new blank one, when I press the Record button I get two red triangles at the top left of the track and the only other thing that works after that is the Stop button. Here’s a pic…
3.0.4 record button freeze.JPG
Nothing has changed in my setup. My studio mic is plugged into my PreSonus Audiobox USB, it is configured for mono tracks, 44.1 Kz and 32 bit float. I checked the sound settings in Windows and everything matches. This is on my primary computer. Oddly, Audacity on my laptop (same operating system) records just fine. Anyone else having this issue?


Pretty sure I solved my own problem.

I checked the presets for the Audiobox USB and its inputs and outputs are set to 24-bit, not 32-bit.

As soon as I set the tracks to 24-bit, I was able to record again. Sorry for taking up your time! :confused:


I am not sure that the one had anything to do with the other. Also, when you switch to 24bit, you lose your floating point protection, which protects you from signal overflow during processing such as any kind of edits. Others may be better at advising you in this area than I.