Audacity 3.0.2 on Fedora 34 saves "Empty" projects

Since installing fedora 34 and, with it, audacity 3.0.2, I’m having some strange problems.
Worst of all, when I just tried to save and then reopen a new project it turned out to be empty. No dialogue about file recoveries at all, just plain emptyness. I tried opening an older (.aup) project and it too was empty.

It seems like audacity saves everything including audio tracks in a single .aup3 file with the new version. For the emptied project I notice that this file is suspiciously small, about 300 kB instead of hundreds of mb as it would be with all audio properly stored.

I should add that saving projects and opening them worked for a short while before not working anymore. Is there any other information that might be helpful while I wait for a more stable release?

This seems like a serious issue, so I moved this post to its own topic so hopefully it will gain more traction.

What sort of drive is the project stored on, and what format is the drive?

(I’ve been using Audacity 3.0.2 for nearly 2 months, and I’ve not seen any stability problems at all. My version is built from source on Xubuntu 20.04.)

Thanks jademan.

As for drive, I don’t know if I understand the question. The projects are stored on my computer, same diskspace I use for most things.

Some more details about what’s going on:

When I create a new .aup3 project it seems to save everything and the file size is appropriately big. Then when I close and reopen the file it turns out to be empty, meaning the tracks are blank but the track names are still there. Next, when I close the project again the file size plummets to just a few hundred kb.

Run this command in a Terminal window. Copy and paste the output into your reply.

df -h --output=source,fstype,size,used,avail,pcent,target -x tmpfs -x devtmpfs -x squashfs

(This will list details about only mounted file systems, filtering out types that we are not interested in).

File system Type size used free used% Mounted
/dev/mapper/fedora00-root ext4 50G 20G 28G 42% /
/dev/mapper/fedora00-home ext4 862G 531G 288G 65% /home
/dev/sda1 ext4 477M 218M 231M 49% /boot

This is the one that I was particularly interested in.
It is formatted as “ext4”.
That’s blown one theory out of the water - that’s not the problem.

Do you work with several Audacity windows open at the same time and copy/paste between them?

My general habit is to keep only one audacity window open at a time. However, I can successfully copy and paste audio between two open projects.
Exporting soundfiles also works.

So, any remaining theories about what has gone wrong?

I had the same problem with either the audacity package or the audacity-freeworld one (from rpm-fusion). However, I could successfully open and edit the project with the Flatpak package (from Flathub) It seems that the project is properly saved but cannot be opened for some reason.

Same issue here, using Fedora 34 with BTRFS… Could it be FS?

I’ve never used btrfs and know little about it, but I did find this:

Same problem here.

My project has a stereo track with audio from an imported mp3 and a mono generated track. I saved the project but when I reopen it I have my 2 tracks (stereo + mono) empty.
My fs is ext4.
Launched from terminal I can’t find any relevant.
Nor an error or warning is issued by the program.

Do you know if SQLite was compiled with SQLITE_ENABLE_DBPAGE_VTAB?
Apparently this is a requirement for AUP3 project files to work correctly, but is not the case for some Fedora users.

How can I check that it is compiled with SQLITE_ENABLE_DBPAGE_VTAB?

From the .spec file I see this

               -DSQLITE_ENABLE_FTS4=1 \
               -Wall -fno-strict-aliasing"

The option is not present, should I file a bug in Fedora?

If this helps, I checked the file sizes and all project are the same: 327680 bytes.

Sorry, I don’t know that. It was just something that came up when searching online for similar issues.

I’ve just saved an empty project using Audacity 3.0.2 on Xubuntu. The file size of the empty project is 327,680 bytes.

When you open an AUP3 project file, there should be a WAL file created with the same base file name, but with the file extension “.aup3-wal”. Are you seeing that file?

Yes. The file aup3-wal is 0 bytes. It grows when I add content to the project.

Test sequence so far:

  1. open the project with empty tracks → aup3 is 327680 bytes, aup3-wal is 0 bytes
  2. add an mp3 file → aup3 is 22740992 bytes and aup3-wal is 28256392 bytes
  3. save project → aup3 and aup3-wal have the same sizes as previous
  4. close audacity → no change in aup3, aup3-wal is gone
  5. reopen audacity and open project → aup3 is bigger than 327680 bytes and aup3-wal is 0
  6. close audacity → aup3 is 327680 bytes

That all looks normal.
(The WAL file is a kind of temp file for the project. Technical details here:

How exactly are you opening the project?
What is in the Audacity Log file after opening the project (there will be a lot of stuff). “Help menu > Diagnostics > Show Log”

Opening the file with Open, double click or recent. It doesn’t matters.
Nothing is traced in the log

:open_mouth: Nothing at all?
There should at least be some information about loading FFmpeg.