Audacity 2.4.2 will not record from streamed music

I have installed Audacity 2.4.2 but cannot record from streamed music (or a music file playing on my PC), using the red ‘record’ button. There does not seem to be a basic settings problem for recording a stream on my PC because I can record from these sources using Ocenaudio. I can then open the saved file in Audacity and use all the editing functions (which are impressive).

I run Windows 10 version 2004. Stereo Mix is enabled and the volume bar shows it is active. Microphone access to apps in Windows 10 settings is enabled. I have tried every combination to record the stream in Audacity – MME and WASAPI, Stereo Mix (Realtek) and Speakers Realtek (loopback), but depending on which I try I either get error code 9996 Invalid Device or 999 Unanticipated Host Error.

Is this a basic problem with Audacity 2.4.2 and Windows 10 2004 please? If not, what am I doing wrong please?

To use WASAPI loopback, the audio devices settings in “Windows Sound” should use a sample rate of 44100 in both the Recording AND Playback tabs.

Many thanks for answering - I set both to 44100 but it still will not record

What is it doing? Error message? Recording silence? Something else?

Thanks for replying. With WASAPI and Speakers RealtekHigh Definition Audio (loopback), and with WASAPI and Stereo Mix, I get Error code 9996 Invalid Device. With MME and Stereo Mix I get Error code 9999 Unexpected Host Error.

Those error messages indicate problems with the device (or device drivers).
What sort of computer are you using?

I appreciate perservering with this - thank you. It is an HP 8300 Elite Intel i5 3470 @ 3.20 Gz 240 GB SSD. Fairly old, but refurbished and the hard drive replaced with SSD hard drive. As I said, I can stream record with Ocenaudio, so the PC has the drives etc that enables it to record from streamed music, at least witrh Ocenaudio, although using 2 apps to stream record then edit is not ideal

I checked on the HP website to see if updated drivers were available:
Unfortunately for the HP 8300 there only seem to be drivers up to Windows 8.1 - no drivers for Windows 10.

The do provide an online “Audio Check” tool. I don’t know what it does, but it may be worth trying.

Many thanks for all your work trying to sort this out - it is much appreciated. The tool you suggest does not help, but thanks for suggesting it. As Ocenaudio is able to record from the stream, so the drivers I have work for this running Windows 10, I will record with this and edit in Audacity. It does seem, perhaps, that Audacity has got rather complex for stream recording and assumes that all users have a fairly new PC - it would be good if it could work with the same drivers etc as Ocenaudio on PCs running Windows 10

I am having a similar issue trying to record my DAW (STUDIO ONE) output through Audiobox audio interface into my laptop. I was able to record You Tube, Spotify streaming via loopback but Audacity won’t record Studio One. I’ve tried every setting possible, I think. I upgraded my laptop to Windows 10 and I’m thinking of going back to Windows 8.

I don’t know what drivers Ocenaudio uses, but if it uses ASIO drivers then that’s not possible for Audacity due to licensing restrictions. On Windows, Audacity uses Windows drivers.