Audacity 2.4.2 stops playing an MP3 import

Apologies if this issue has been covered, but I have spent a long time searching and can’t see it. Audacity 2.4.2 running on Windows 8.1.

I have used Audacity for a few years to produce clips from some of my MP3 files for a regular music quiz I host for family and friends. Recently, after I have successfully created new MP3 files for my clips, a newly imported MP3 file loads OK, but will not play when the Play button is clicked. Instead, the Play/Record Head button appears at the start of the track, at the same position as the Playback Start Position cursor.

I have tried various things to remove this to get the track playing, but the only cure is rebooting my PC, and then after a few more successful projects, it happens again.

All suggestions appreciated.

Are you using a USB audio device?

Try “Transport menu > Rescan Audio Devices”, then check that the correct devices are set in the Device Toolbar.

Thanks for that. Yes, checked all that OK, reloaded MP3 file, and sam problem. Also, after loading file, “Rescan Audio Devices” greyed out.

How big are the MP3 files?

Typically 4 - 8mb. The strange thing is that I have been using exactly the same procedure over the last few years, and produced hundreds of clips with no problem, and my setup hasn’t changed. I was wondering whether to uninstall then re-install.

Given that Audacity works with 32-bit uncompressed audio, importing an 8 MB MP3 file may expand to over 150 MB of audio data.
How much free space is there on your computer’s C:\ drive?

775GB available of 889GB.

Where are you “loading” the file from? Is the file stored on your local hard drive?

“Rescan Audio Devices” should not be greyed out unless Audacity is “busy” doing something. Does the import actually complete?

Yes, all files are held on the hard drive.

Yes, the file has fully loaded OK when the “Rescan Audio Devices” is greyed out, and Audacity is doing nothing else.

Did you get Audacity 2.4.2 via the Audacity website? (The download is served by our content delivery partner “FossHub”). If not, I’d suggest that you completely remove Audacity from your computer, run a full malware / virus check, then download and install Audacity from the above link.

If you did use the official download, I’d suggest that you download a new copy (the recommended “EXE” version) and check the integrity of the download (See:
Then re-install Audacity and select the option “Reset Preferences” during the installation - that will reset Audacity back to “factory settings”.

I did download Audacity through the official site - I’m always wary of general download sites. I’ve just downloaded again (Publisher James Crook?), saved to the same location, re-set preferences, and the same thing is happening. I can’t even close the project under the File menu as “Close” is greyed out.

That’s correct. He was the acting release manager for Audacity 2.4.2, so the app’s certificate is signed in his name.

This all sounds very strange. Is Audacity completely freezing?

No, although many commands are unavailable. For example, in the File menu only Recent files, Save project, Export, Import and Exit are usable, everything else greyed out. That applies across the menus - a mixture of what I can use and what I cannot. If I move the cursor along the track and click “Play”, the green triangle simply appears again at that point and nothing happens.

I may be getting closer to the answer. ITunes, my default media player, will not play any files either.

Problem solved! I use a pair of USB speakers on my laptop, and the problem must have happened after an automated Windows 8.1 update. Although the speakers were still shown as the selected playback device, and I can’t select them as default speakers, I clicked “Test”, got the ping, and now everything works again.

Thanks for your suggestions on this one, and a special thanks to Microsoft.