Audacity 2.4.2 doesn't recognize USB cassette on my iMac

I’m using a 2020 iMac 3.3 GHz 6-Core Intel Core i5 with 32 GB 2667 MHz DDR4.

I just got Audacity 2.4.2 installed and when I play the cassette tape the audio is not recognized by the software. It is only giving me three input options: Display Audio, iMac microphone and MOTU 896mk3 (DAW). So when I start the cassette player, then press the record button in Audacity I’m not getting the source sound (from the cassette).

I’m not the most technical type of person so maybe I’m just missing a step here.

My goal is to transfer old songs from a cassette player to mp3 files. The cassette player I bought is designed to do this as it has a USB cable. Also, the iMac sees the USB input under, About this Mac>System Report>Audio. Its sees the device as USB PnP Audio Device.

Any help would be appreciated.


That’s a red flag. It’s one of those $40 cassette-to-USB things, right?

Go to Apple menu > System Preferences > Sound > Input. See if the device is shown in that list. If so, select it and then start playing a cassette. Does the input meter bounce? Does the device disconnect after a few seconds? If you get sound input and the device doesn’t disconnect, start Audacity and try to record.

[Note that you should connect any external audio devices before starting Audacity, but if you forget you can always go to Transport (menu) > Rescan Audio Devices.]

We have not found any way to get these devices to work reliably with Macs. There is some speculation that they may be drawing too much power from the USB port and that connecting them through a powered USB hub might help but we have no evidence of this. Of course, we also suggest that user do not connect audio interfaces through a hub due to timing issues. So there seems to be a “conflict of interest” here.

Let us know how you get on.

– Bill

I know the instructions say you don’t need batteries with USB, but have you tried this with batteries. There is again, speculation, that this has the potential to correct the problem, and I don’t know if this has been tried yet.

Thanks for the ideas.

Yes, I’m sorry to say this is one of those $39 cheapie Chinese-made devices. It is the cheapest device I have ever laid eyes on. So I tried the Preferences>sound monitor and it does recognize the device, but then it goes away and comes back and goes away again. So apparently it’s intermittent and unreliable.

I also tried it on a pre-Big Sur mac and the same intermittent problem happens. I think I’ll try to pick up a better device and try this again.

Just to be clear, the device appears and disappears from Sound Preferences whether or not you press play?
– Bill