Audacity 2.3.3 Won't record audio via alesis Io2 on windows 10


I’ve upgraded to Audacity 2.3.3 on Windows 10 and can’t record any audio via my Alesis Io2 on my Surface pro 3

I get nothing or get the error message “Recorded audio was lost at the location. Possible causes: Other applications are competing with Audacity for processing time. You are saving directly to a slow.external storage device”…I’m doing neither.

The Alesis is working…all lights flashing. Tried Mono and sterio settings…using guitar socket.

I’ve turned on my microphone on Windows for Audacity, set the Bit rate for recording at 24 bit, tried bit rate 32… set the project rate at 441000 HZ

The Alesis is recognised and tests as functioning on my laptop (Surface Pro 3) 64 bit

Nothing shows on the microphone monitoring on Audacity when I try to record.

These are the the settings for input/speakers are …MME…Microphone.Io2, tried mono and sterio record, output Realtek (also tried Io2)

can record via other microphones on Audacity…

I don’t know what else to try…

Cheers n stay safe y’all