Audacity 2.3.3 initiates Quit during long unattended recordings

iMac 27" mid 2011
2.7G quad i5
1TB HD (NOT a Fusion drive)
OS X 10.13.6 High Sierra
Audacity 2.2.3

I use Audacity to make long, unattended recordings from a streaming app into Soundflower into Audacity. The streams are about 2 hours in most cases. I start recording, then make periodic progress checks. Once I see the stream has ended, I stop recording and save the project for later edits.

Since moving from 1.5.1o to 2.2.3 two weeks ago I have had odd behavior.

When making a progress check, I am seeing recording already stopped and the dialog box normally associated with Quit…save, not save, cancel. Last night, this happened before the stream had even completed (about an hour had been recorded). This morning, trying the same stream again when I made a progress check the stream had completed, but again recording had already stopped and the dialog box was on the screen. I’m not sure if it’s due to an unexpected shutdown or just an unexpected quit.

The only apps running at the time are the streaming app, Audacity and System Preferences which I keep open so I’ll remember to switch output from Sountower to Built-In Output. I have sleep and Time Machine both disabled.

If I can’t fix this, I’ll have to revert back to 1.3.10.

Please check the Audacity version number. If it really is “2.2.3” then something is very wrong.
(Look in “Audacity menu > About Audacity”)

My bad, I mistyped…it’s 2.3.3

Is there a reason that you don’t use “Timer Record”?

How do you see that the stream has ended?
Is the “streaming app” a web browser, or something else?

Was the “streaming app” still playing?

Are you getting critically short of disk space?

I didn’t know that existed, I’ll give it a try.

The app is Spotify. I just look to see playback of the playlist has finished. I also do unattended recordings of LPs and cassettes, but that is via an audio interface direct into Audacity, not via Soundflower.

FWIW I am a paid Spotify Premium user with an old iPod Touch that cannot be updated to latest version of the app and is now totally unsupported, because of changes at Spotify’s back end many of the features are no longer functional including access to my own playlists :unamused: , including downloading them to the iPod…one day it just stopped working. I export the recorded playlist into iTunes and transfer to the iPod solely for playback in my car. This is a PITA stopgap until I can afford a newer iPod or other mobile player that works with Spotify.

No, but I had waited long enough to check that Spotify should have stopped. I don’t know if it actually stopped in the middle for some reason.

No, over 50% free space on a 1TB drive.

Since reverting to the older version of Audacity I am not seeing the problem. I’ll try the timer feature and see how that goes, thanks.

OK, I tried the timer feature. The recording stopped early (notice the elapsed time is only 1:35, not 2 hours…the stream was supposed to run for 1:53) and it’s clear that the Mac is shutting down for some unknown reason. Spotify was already closed and shutdown was stalled waiting with the dialog box open. Screenshot from 4:09PM (about an hour after recording ended, apparently) is attached.

Screen Shot 2020-03-18 at 4.09.01 PM.png

I’m guessing that if you leave your Mac switched on and unattended, with no applications running, it will shut down within a couple of hours. Please test and let us know what happens.

I leave the Mac on all day quite often, usually with sleeping disabled. It simply stays on.

I do not have this behavior from any other application I run on the iMac, including DAWs (Logic, Reason), photo/video editing applications browsers. I was not seeing this until I upgraded to 2.3.3.

I have already gone back to an older version of Audacity. If I have the spare time, I’ll look into the system logs and see if I can see what might have triggered the shutdowns.

Thanks for your help.

Finally figured it out.

Hidden in Mac OS system preferences is a setting I had no idea even existed. In Security and Privacy selecting the Advanced menu showa a setting to log out the current user when there has been no activity for 60 minutes. Using the timed recording feature in Audacity only made the problem worse by leaving Audacity unattended for two hours. Apparently when making regular checks to see if the recording was done, I had never waited longer than 60 minutes between checks before. The fact that I had just updated to 2.3.3 had nothing to do with it after all.

Boy do I feel like a dope… Thanks for your help!

Thanks for letting us know. Glad to hear there was a simple explanation.