Audacity 2.3.0 update gone wrong

Hello,

I have a serious issue using Audacity after I updated it from 2.2.2 to 2.3.0.

If I try to use the distortion effect, Audacity crashes.

I tried to reinstall it through apt-get, but it didn’t help.

Please help me how to fix that or how to go back to 2.2.2. :smiley:

I need it quickly.

My operating system is Linux Mint 18.2 cinnamon.

I figured out by myself how to revert to 2.2.2 and did that.
I’m just going to skip 2.3.0 in the hope that 2.4 will work better.
But thank you :mrgreen:
Thread can be closed. :mrgreen:

Audacity 2.3.0 should only be used on Windows and Mac. We had the Linux tarball (marked as “Experimental”) for a short while, but too many people were installing it as a “production” version, so we have now removed it completely from the Audacity website.

The next release of Audacity is likely to be Audacity 2.3.1 and is planned for Windows, Mac and Linux. It is currently scheduled for January 2019.

Yes, this is the major bug in 2.3.0 on Linux and it affects all effects that have “real-time preview”. If you are building from the source code, there is actually a simple fix, though it is probably better to just stick with 2.2.2 until 2.3.1 is released.

That update is distributed through the update manager from Linux Mint and it is still available in the repository (Linux Mint uses the Ubuntu repositories). They handle it as a stable release. That would explain why many people have got that update. :open_mouth:

A “sudo apt-get install audacity” still gives you 2.3.0 :confused: :angry:

So if this is a beta release, it’s pretty bad news for novice users who don’t know how to get a working application out of a tarball. :cry:

2.2.2 isn’t available anymore in the repositorys (or never was, I don’t know anymore if I installed the original 2.2.2 one by tarball or by repository^^). There is only one very outdated alternative available (2.1.x).

I simply made a .deb from the 2.2.2 source and installed that through the package manager (so I can uninstall it and install the official version again once the the issue is over).

I could do the same from the 2.3.0 source too.

Is that bugfix easy to implement so I could modify the code by myself before I run the compiler? I guess it is NullPointerException caused by a missing null check or something like this? If so, please tell me, which version of source code I should use and which lines must be modified in which files.

It shouldn’t be, though it may be listed in some PPAs.
I’m aware that the “Panda Jim” PPA has it (Audacity Audio Editor and Recorder : Panda Jim).

Audacity 2.3.0 is not listed in Ubuntu’s package search: Ubuntu – Package Search Results -- audacity

Yes, there’s a missing null check around line 4821 in src/Menus.cpp

auto parent = focus->GetParent();

should be

   wxWindow *parent = nullptr;
   if (focus != nullptr) {
      parent = focus->GetParent();
   }

or as one line:

wxWindow* parent = focus ? focus->GetParent() : nullptr;

This is now fixed in the 2.3.1 alpha code.

That’s great.

I applied that fix and now I have a working 2.3.0 on my computer :mrgreen: .

Thank you!!! :mrgreen:

Another bug has just been found.
If a project contains any “Note” tracks (MIDI tracks) and you open the “Mixer Board” (from the “View”) menu, Audacity crashes.
The fix for that is here: Bug2004: Opening Mixer Board with a Note track crashed... · audacity/audacity@3f928a2 · GitHub

I don’t need that feature.