Audacity 2.3.0 not recording

Hi,
I use audacity all the time. It is a great program, and I really like it. But lately I have tried to just simply record using the built in mic. It won’t pick up anything. I feel like I am just missing a simple setting… I went to all the preferences I could think of, I tried every one I know of but it still won’t pick up any audio. I’ve never had this issue. My laptop works just fine, I checked all the settings on that computer and they seem to be the same as the one I am having issues with. If any light could be shed on why it is not picking anything up that would be great. I did try plugging in a USB and when I did it picked up audio from that, but as soon as I switched it went blank. Now, I feel like its a computer setting problem???

However, what I acutally want to be able to do is to record something internally on my computer. I could not get that to work either. I do have soundflower and it works on my laptop but when I switch all the settings to soundflower on the problem computer it just comes up blank?

While I’m at it I’ll ask one more thing and I then could avoid most of this, though for other things I still want audacity to be working properly. I have a 30hr long recording that I need to cut up, does anyone have any suggestions on how to do that besides internally recording it in bits at a time. Also, the file isn’t mp3 so I can’t upload it to any of my devices. It has all really put me in a pickle.

Thanks for any suggestions,
Hope

  1. Is the new machine running macOS 10.14? If so, go to System Preferences > Security and Privacy > Privacy. Click on Microphone in the left panel and make sure that Audacity is allowed access to the microphone.

  2. Fixing #1 may fix this. But Soundflower is no longer supported. iShowU Audio Capture is now the preferred solution for capturing audio playing on a Mac.

  3. 30 hours is longer than Audacity can support in one project. It looks like you’ll have to record it in bits. At least you’ll be able to walk away while it is recording.

– Bill

Thank you, I will try all that.

I tried everything. It seemed that when I turned audacity on it was messing with with the internal speaker and shutting it off so somehow the mic wasn’t picking up anything either.

I also uploaded iShowU Audio and it works great.

Thanks again as I was getting frustrated and I knew it was something simple I just didn’t know.

Hope