Audacity 2.3.0 freezing

Have tried Aud 2.3.0 on two Macbooks, one running OS 11 and one running 14. Was able to do convert a couple of tapes with many freeze-ups and reboots along the way, but now I cannot record for more than a few seconds before it Audacity freezes and I have to reboot the Mac. I really would like to know what’s going on.

What cassette deck are you using?
– Bill


I had Audacity 2.3 freeze up on me yesterday, I closed everything else down and did a force-quit on Audacity, fearing I’d lost the file I was working on. When Audacity came back up it gave me the option to recover files not closed properly, so I was back in business.

Bottom line: Audacity is a memory hog. Keep other processes to a minimum.

Yeah, I thought so. There’s many reports on the forum of problems with that device. Try another USB cable if you have one. Plug directly into the Mac, not through a hub. I’ve not used one, but reports indicate it “disconnects” from the Mac (the Mac loses the USB connection) when the deck is turned off. This can result in Audacity crashing or freezing.

– Bill

Actually, Audacity is pretty light on memory use, but it does like to have the use of the CPU when it needs it; that is, when recording and playing back. This leads to the same advice: keep other processes to a minimum.
– Bill

Tried other cable.

Am plugged directly, no hub.

It happens although the unit has not been turned off. If it has recorded ok for 30 minutes on one tape, I don’t understand why it can’t record more than 3 seconds on the next tape.

Also, why when it freezes can I not do a soft shutdown. I have to hold down the Mac power button. Only software I’ve ever had to do that.

Also when it says it can recover files, it often doesn’t.

This is all happening on two different computers with no other programs open.

Its the cassette device. As I said, lots of other users are having similar problems with it.

You should be able to Force Quit Audacity when it freezes.

If you continue to use this cassette device, one way to avoid lost recordings is to do a File > Save Project > Save Project As before you begin recording, and do a File Save Project > Save whenever you pause or stop recording.

– Bill

If the device/cable is the problem, now come I am getting an input level?

After much sturm und drang, I finally got a whole cassette recorded. No idea why it worked or if it will work next time.

Is the USB plug good and tight in the USB socket?

How would I get a good input level if it weren’t?

No idea why it worked

You got lucky. Everybody knows a digital service is either there or it’s not. There is no partial connection or other distortion or damage.

But you can have a perfect digital connection that’s not present all the time. That gives you things like a perfect transfer of five minutes of music…until the humidity goes up…on Thursday. You changed the USB cable, but did you change it to a shorter one? That’s highly recommended as is changing the USB connection on the computer. A connection on the back is more likely to work than one on the front.

I have a Mini where some of the USB connections will not run a keyboard.

One USB Cable is 6’ (2M). If you go over that, Bad Things can happen to the connection. The USB microphone people run into this. A microphone can come with a 9 foot cable, but the microphone doesn’t always work with a cable that long.

There’s a deep philosophy thing, too. You’re going to give the cassette player to your son and grandson, right? No? You’re probably really going to transfer all your tape and put the whole thing in the bin. That means you bought trash. Sometimes the player turns to trash a little too early.


If the plug is a bit loose, or the cable slightly damaged on the inside, you may get USB working some of the time, but not all of the time, or the data could be “mostly” getting through, but sometimes dropping bits (which will corrupt the data). There could be a component in the devices that runs too hot and causes data corruption. There could be a “dry joint” on the circuit board in the device. There are many reasons why intermittent faults can happen with USB devices.

There have been a lot of intermittent problems reported when using “Super USB cassette capture” devices (the same device is badged with a variety of names, including: “Generic”, “HooToo”, “Lychee”, “EZ-Cap” and others).

Everyone wants to blame the player or the connection, but I confirmed I was getting input to the computer. The software should have been able to record that even if it was noise, no? Oh, and I actually tried with two different devices, so I’m supposed to believe both were bad? I mean, sure, it’s possible, but this thing has a 4-star customer rating from hundreds of customers on Amazon. And, I don’t know, but if this is a common problem with USB, couldn’t Audacity be made a little more fault tolerant?

Perhaps you could test the device with other software.

There has been some work in the last couple of versions of Audacity to try and make it more robust against faulty hardware, but that is a very difficult and complex task.