Audacity 2.3.0 crashes with many plugins and the wahwah effect

Hi, Audacity version 2.3.0 crashes with almost every plugin I tested but also the built in “wahwah” effect when I apply it to the audio.

I use Kubuntu 18.10 (cosmic).

I tested this issue with both the PPA maintained by “Panda Jim” ( ppa:ubuntuhandbook1/audacity ) and also the flatpak version of flathub.

2.2.0 doesn’t have this issue (from cosmic repos).

Any ideas? Is this a known issue? Can anyone else reproduce it?

System info:

Kernel: Linux 4.18.0-8-generic x86_64
Distro: Ubuntu Cosmic Cuttlefish (development branch)
CPU:    Intel(R) Core(TM) i5 CPU       M 520  @ 2.40GHz
        4 cores/threads
        2400.00 MHz
RAM:    3.65 GiB
GPU:    Mesa DRI Intel(R) Ironlake Mobile 
        OpenGL 2.1 Mesa 18.3.0-devel
        GLSL 1.20

Every time I try to use the Bass and Treble plugin, there’s a crash. The log says nothing useful. I’ve tried using a new ~/.audacity-data folder, and there’s no change.

Oddly, it does seem to work when used as part of a macro (chain).

If I run Audacity from the command line, all it says is Segmentation fault (core dumped). OS is Ubuntu bionic 64-bit.

Yes this is a bug that was accidentally introduced by a fix for another bug shortly before 2.3.0 was released.
Effects that have “real-time preview” are affected, so that is:
Bass and Treble

A fix has just been committed.

Thanks. Will there be a new release, or is this something I have to patch and build myself?

For now, on Linux, you are probably best using Audacity 2.2.2.
A short release cycle is intended for Audacity 2.3.1. I can’t give an exact date yet, but possibly before Christmas.

If you build Audacity yourself, then it’s an easy fix for this particular problem.
In /src/Menus.cpp
MenuCommandHandler::DoEffect (around line 4818)

   auto parent = focus->GetParent();


   wxWindow *parent;
   if (focus != nullptr) {
      parent = focus->GetParent();

Sorry, but how to get Audacity 2.2.2 after upgrading to 2.3.0? In official repositories (Ubuntu xenial), version 2.1 is proposed …

Thank you for helping me.

The Artful repo still has version 2.2.2:

So you’d add this repo to Synaptic:

And use artful as the distribution. Then refresh, search for Audacity in the package list, select it, go to the Package menu, select Force Version, and choose 2.2.2 from the drop-down.

Many thanks, but…

… when I try to force version, Synaptic says that it’s a broken version!

Hmm… not sure what could be wrong. Might be a missing dependency somewhere. I’m on Bionic, and setting the Audacity repo back to Artful worked perfectly. Xenial is pretty old. Can you upgrade?

Not just for that! Too bad: I stay at 2.1.2! In any case, nothing indicates, on the ‘artful’ repository, for which Ubuntu version the package deb is.

Thank you for your answers. (And sorry for my bad english)