Audacity 2.3.0-and the new Mojave beta

just a quick heads-up. Just found this out today. audacity does not work or load at all under the new Mojave Beta (mac) which is 10.14.4 (18E184e). Goes right to error report. I guess I should have waited to install and try out the new Beta software. I guess that’s why it’s called Beta software, right
:unamused: :unamused: :unamused: not quite exactly ready for prime-time. Could introduce a few bugs and problems, maybe new maybe old… do not install on mission critical computers… Perhaps maybe I should have read the fine print on this one before pulling the trigger… :blush: D’oh…

John B

When the first Mojave betas came out, Audacity didn’t run on them either. Fortunately they (mostly) fixed it before the full release of Mojave.

Have they announced a release date yet? Audacity 2.3.1 (64-bit for Mac) may be out by then.

Wish I’d checked this yesterday! :blush:

Also Audacity 2.3.1 alpha crashes on the latest beta of Macos Mojave 10.14.4 - Same behavior as audacity 2.3.0 on the latest beta of macos 10.14.4 latest beta.

Audacity becomes unresponsive after opening audio file/creating new audio project. This also happens when activating plugins. The crash report window pops up and the I need to force to close audacity because audacity becomes unresponsive with full cpu usage.

  1. What’s the “Commit Id” for Audacity 2.3.1 alpha? (look in “About Audacity > Build Information”, near the bottom).
  2. Where did you get the Audacity alpha version from?
  3. Is it a Debug build or Release build?
  4. Does this Audacity build work correctly on the release version of Mojave?

Freaking same. It loaded up just fine in the beta, I recorded a project, then when I hit save, it’s in crash cycle hell.

The tested build of Audacity is 2.3.1 alpha 42e0cd Nov. 11 2018.

I’ve got this build from

The problems exist from one the lates macos 10.14.4 beta (public beta 4).

Thanks for the reports. I have added a note to the Audacity website to make it clear that the current release version of Audacity is NOT for macOS 10.14.4 beta.

There is also an announcement on the Mac forum board: macOS 10.14.4 beta - Important information.

As you can see from the date, that is quite an old alpha version. I have asked on the Audacity developer’s mailing list if they could upload the current alpha version for testing.

I’ve contacted Apple withe beta feedback assistent. They still did’nt contact me back.

Today i’ve receaved macOS Beta version 10.14.4 bèta (18E194d).
Audacity 2.3.1 beta from nov 11 2018 works without any crashes, seems that apple dit fix some problems on macOS.
Newer beta builds of Audacity 2.3.1 are still not aviable, latest build is v2.3.1 42e0cd Nov. 11 2018 @