Audacity 2.1 crashes [SOLVED]

Hi I have Mint Cinnamon 17.3. I have recently installed Audacity 2.0.5 through my software manager. I can create files by recording from my sound card but if I try and load an already existing file the program crashes.
This is a new 64 bit version of Mint. It is dual booted with a 32 bit version on which Audacity runs ok.

I have un-installed it once and re-installed it without success.

Topic split from other thread.

As you posted in a topic about Audacity 2.1, could we start by clarifying whether you are currently using Audacity 2.0.5 or some other version.

OK it is 2.0.5 installed through the software manager in my Mint 17.3 system.

Do you open an Audacity project (AUP file) or import an audio file (like an MP3 or WAV)?

What version of wxWidgets is 2.0.5 built with? Look at Help > About Audacity… then the “Build Information” tab. If it says wxWidgets 3. then it as a corrupt Audacity version built with a version of wxWidgets that 2.0.5 was never intended to support. You would do better to uninstall it then install the “2.1.2-1~14.04” PPA package from Audacity Audio Editor and Recorder : Panda Jim.

If 2.0.5 is built with the intended wxWidgets 2.8.12, you could try exiting Audacity and deleting the folder ~/.audacity-data/. This will reset Audacity to factory settings. If you are importing files, try importing them into a new empty project rather than into an existing project which may have become corrupted. You can export WAV files from corrupted projects and import the WAV files into an empty project to make projects stable again.

Even if 2.0.5 is built with wxWidgets 2.8.12 it is still a very old version of Audacity, so the 2.1.2 PPA may be more suitable.


Gale

I import .wav files into what I presume is a new project. After editing these I export them to a local drive. I have never saved a project.

It is built with wxWidgets 2.8.12.

I deleted the .audacity-data folder and re-started Audacity. When I tried to open a .wav file it crashed.

As I said in my first post this 64 bit system is dual booted with a 32 bit system. On the 32 bit Audacity runs ok.

To ensure you have a new, clean project, either restart Audacity or do File > Close.

You do need to understand that Audacity 2.0.5 is now very old. Also Audacity Team does not supply the Audacity packages that are offered by Linux Mint or by any other Linux distribution. It is thus entirely possible there is a packaging error in Linux Mint’s 64-bit 2.0.5 package, or a problem with the system libsndfile library on 64-bit Linux Mint (libsndfile is used for importing or exporting WAV files).

I would still try uninstalling 2.0.5 and installing the 2.1.2 PPA. If WAV files still crash on import that does suggest a problem with the libsndfile library. We can’t fix that - you would need to report it to Linux Mint or build Audacity yourself with the libsndfile we supply.

It is also possible the specific WAV files you have are corrupt. To test that, Generate > Tone in Audacity and export as WAV 16-bit PCM. Drag the WAV back into Audacity. If that does not crash, please post the problem WAV file on Dropbox or your favourite server and give us the download link for the file. Then we can see if we can reproduce the problem.


Gale

Files have crashed in a freshly opened project.

I did the ‘Generate > Tone’ and saved it as a project and exported a .wav file. The project opened successfully but the .wav file crashed using the File>Open route. After rebooting I re-read you post and tried dragging and dropping it. It crashed again.

How do I install the 2.1.2?

I am almost expecting now that 2.1.2 will crash too.

Uninstall 2.0.5 using the same method you used to install it.

Visit https://launchpad.net/~ubuntuhandbook1/+archive/ubuntu/audacity.

It might be best on Linux Mint to open your software sources and add these lines manually:

deb http://ppa.launchpad.net/ubuntuhandbook1/audacity/ubuntu trusty main



deb-src http://ppa.launchpad.net/ubuntuhandbook1/audacity/ubuntu trusty main

If you use Synaptic, you can open the software sources from Settings > Repositories.

Then open a terminal. Paste or type:

sudo apt-get update

and hit ENTER on your keyboard.

Paste or type:

sudo apt-get install audacity

and hit ENTER.


Gale

I might have done the first two bits incorrectly because at the end of all that I’ve got 2.0.5 again and it still crashes when I try to load a file.

I’ve just done it again and it has worked. Audacity 2.1.1 has now loaded a file that crashed the previous version. Thanks for your help.

Just to be clear, you mean the 2.1.2 PPA from Audacity Audio Editor and Recorder : Panda Jim?

Gale

I’ve checked again and it’s version 2.1.2. I successfully edited 10 tracks this morning. Thanks again.

Sorry, I missed your last post with the page change. I followed your steps of un-installing and adding text to Software sources and then re-installing. The second time I tried it I got the 2.1.2 and it works fine. Thanks again for your help.