Audacity 2.1.3: incorrect speed and pitch

<> This is the translation (by Google Translate, from french to english) of the following topic:



I started with Audacity 2.1.3 on Xubuntu 14.04.4 (I am also relatively novice on Linux!).

Firstly I can no longer go into the preferences for the last Updates (kernel? Audacity?).

But Audacity seems to work; however, the pitch and speed of sound recordings from my browser aren’t correct (I have not tested other sources, with no microphone). To restore (after trial and error) the situation, I have to go in Audacity by: Effect> Change the speed. An increase of 10% seems correct (in the ear).

I wonder why this error occurs and, above all, how to eliminate it to avoid having to correct speed and pitch after each record.

Thank you for any help (and thank you for your patience: I am not familiar with this type of difficulty).

Audacity 2.1.3 does not exist yet as a release. They are only alpha builds. Where did you obtain “2.1.3” ?

Which Preferences are you referring to? Xubuntu Preferences? Contact Xubuntu about any bugs in their operating system.

This is quite common on Linux. You may be able to download the audio or video rather than record it. Use your favourite search engine to find out how. Make sure you have copyright holders’ permission before you record or download.

If you must record it, try changing the project rate bottom left of Audacity. If it is on 44100 Hz, try 48000 Hz, or if it is on 48000 Hz, try 44100 Hz.

It is a sample rate problem, possibly with PulseAudio assuming you are choosing the “pulse” or “default” recording device in Audacity. If you are not choosing pulse, doing so might possibly help.


Hello, Gale. Thank you very much for your explanations. I do not know how version 2.1.3 Alpha was installed! I completely uninstalled Audacity and reinstalled Audacity 2.0.5 with Ubuntu Software Center: everything works much better !!! :wink:

I meant access to parameters of Audacity (settings). A crash occurred whenever I tried to access it.

Download is not possible for Internet radio streaming. Is it ?

Why not, indeed?

As I said, reinstalling Audacity 2.0.5 seems to have solved the problem … I hope it does not reappear.

Thank you again for your help.

That is not a known problem in 2.1.3-alpha. I use it (compiled from source code) on Ubuntu 14.04 and 16.04.

Sometimes download is possible. It may breach the terms and conditions of the site, but if so recording may breach those terms also. Check the conditions.


How do I understand this information? Can I tell you that 2.0.5 works perfectly now, but 2.1.3 did not allow me to access the settings (systematic crash)?

For information, I don’t know compile from source files. I necessarily made an installation from a repository (which??? :unamused: => I made a big cleaning, I don’t know anymore! Probably: ppa:ubuntuhandbook1/audacity).

I just read: “Uninstall any packaged version of Audacity before installing the PPA.” (here) ; probably I did not take this precaution!..

We are just telling you that there is no known crash as you describe on our machines. But you could have had bad settings then.

To reset settings, exit Audacity and delete the folder ~/.audacity-data/ .

That site does not have 2.1.3-alpha. Probably you had which has 2.1.3-alpha despite the file names.

Anyway, if you are happy with 2.0.5, and it works, just stay with it.