Audacity 2.1.2 won't open on Windows 10

This just recently started happening. It didnt happen the last time I loaded Audactiy, about a week ago. I have not made any changes to my system since then. It was working last week. What happened and how to fix it? I have tried re-installing it and restarting my computer. No help.

System Restore?

Is a system restore absolutely necessary? Ive done it before, it’s more of a hassle than it’s worth half the time. Is there anything else to try?

It just displays the loading sign at the center of the screen and gets stuck at it.

I don’t know what else to say. If it were mine, I might reset Windows to fresh install and reinstall the apps one by one until I find which of them conflicts with Audacity. Extreme, I know.

Come to think of it, have you installed or updated anything since Audacity last worked? Have you tried the latest Audacity nightly build?

Enable “Reset Preferences” when you reinstall Audacity, which gives you factory fresh settings. See this FAQ which has a lot of things you can try:

If a bad Windows driver update has affected your audio device, you can roll back that update in Device Manger (look in the “Sound, video and game controllers” section for your sound device then right-click over the device). Then you will need to prevent that bad update being applied again - see


Turns out that the classic windows calculator for windows 10 was conflicting with audacity. How, I dont even know.

Oh well, now have to deal with the fugly (Yes, I meant to say fugly) windows 10 calculator. Windows 10: Ten steps back.

I apologize for the double post, did not see the new reply. I already tried that, it didnt work. I have fixed my problem however. Thansk for the tip.

How did you find out it was the fugly calculator?

Do you mean this: Old Windows 7 Calculator for Windows 10 ?

If so, that does not come with Windows 10.


No it doesn’t but Audacity still won’t open when it’s installed.

Do you find that too? 2.1.2 and 2.1.3-alpha open for me on Windows 10 with that calculator installed, whether it is running or not. I do have Visual Studio installed for building Audacity.

Also I did run the modern Windows calculator just before running the old one. Does that make a difference for you? To test, press the Windows key, type “calculator” (without quotes) and choose the “Trusted Windows Store App”.


No, I was speaking on the thread starters behalf.