Audacity 2.1.2 with Windows 10 freezes during editing

When working with a file, Audacity has started taking long naps. This problem arose a few weeks ago (mid-May or early June, 2016). For example, after Audacity performs a high pass filter function, it freezes for a minute or two before it can do anything else.

As another example, I’m listening to a recording and hit the Pause button. When I toggle the Pause button again, it resumes playing. But if I hit the Stop button and move the cursor back a few seconds, I can go visit the restroom while waiting for the recording to begin playing.

This happens regardless of whether I work with the .aup file before saving the project or work with an imported mp3 file. For example, my recordings average an hour in length, so I tried exporting the file as 15-minute MP3 files, quitting Audacity, and then restarting it and opening just one of the mp3 files. This did not help.

I also set the mode to monaural and the bit rate to 22 kbps to minimize file size.

And I re-installed Audacity.

The pauses waste a lot of my time. Either I sit and daydream, or I switch-task – and multitasking is a very inefficient way to work. I hope I don’t need to look for a different program.

I hope I don’t need to look for a different program.

You should probably go ahead and look. We may not be able to resolve this and it would be good to get a head start if you need a new or different skillset.


This is the behavior of a machine running out of resources.

You mentioned multi-tasking. Maybe your machine isn’t up to keeping a bunch of different applications up at once, even if they’re napping. Skype in particular is not a shy and bashful application.

When was the last time you restarted the machine from cold, dead off?

I also set the mode to monaural and the bit rate to 22 kbps to minimize file size.

You should not need to damage the quality of the production to get this to work. That is another indication of a starved machine.

Reinstalling Audacity doesn’t reset Audacity. If you want to burn it off, hose it down and start over, you do that from the Audacity Windows installer. You will be presented with an option to reset all your preferences and settings. Say yes.


That one is a known Audacity slow down, but it should only be happening with longer tracks or large numbers of tracks.

That does sound like you have too many tracks on top of each other. Do you?


Yay, I fixed it! (At least, for now.)

My laptop probably is starved for resources, but the cause was elsewhere. Microsoft must have done something in the last update that affected Audacity. The key was the first step in this post by Kim Komando:

Slow computer? 10 ways to make it run faster

The instructions didn’t work for my setup and only got me part way to the solution. On my laptop:
Control Panel > Troubleshooting > Programs Run programs made for previous versions of Windows

Step through the troubleshooter, selecting Audacity from the list and using the I don’t see my problem listed option.

When it asks, Which version of Windows did the program work on before? select Windows 7.

Use the I don’t see my problem listed option again.

When I tested the program, the window asking for permission to run as Administrator popped up behind active windows. I found it in the taskbar.

On my laptop, Audacity now opens at least ten times faster and runs lightning-fast.

Thanks, richwheeler.

So if you right-click over audacity.exe, Properties, then look at the Compatibility tab, is Audacity now set for compatibility for Windows 7?

Almost no-one has ever found that helps any problems on Windows 10, but thanks for letting us know.


Well, that “solution” lasted about one week.

Thank you, Gale Andrews, for pointing me to check compatibility in the properties of audacity.exe. It was set to run in compatibility mode for Windows 7. I ran the compatibility troubleshooter again and let it use the recommended settings. I don’t see that it changed anything (it is still in Windows 7 mode), but it’s back to normal speed.

If I have to keep resetting the compatibility mode, maybe Windows 10 is doing something nasty.

I’m going to answer some of the previous comments, just for the record.

I watched the performance using the Task Manager, shut down other programs, etc. I don’t think the problem is multitasking or a shortage of resources. I have some audio files I can offload to a backup drive, though, so I’ll add that to my to-do list.

The machine goes into a coma sometimes, so I restart it several times/week. It may correlate with Avira antivirus updates. I’ll add reinstalling Avira to my to-do list.

When I reinstalled Audacity, I used IObit Uninstaller, which cleaned up the folders and references in the registry.

The freezes are new. I used to edit hour-long files with higher bit rates. I understand those pauses. The pauses now are orders of magnitude worse, even with files that are 1/20 the size.

Again, there’s only one track. I also exported to MP3, closed Audacity, and reimported the MP3 to eliminate all the editing scraps.

If you trust Audacity you could see if there is any setting in Avira to exclude Audacity from scanning.

As I said, the delay drawing the waveform after an effect is at least partly Audacity’s problem.

The delay to start playing the audio could possibly be due to having incorrect audio drivers. If you upgraded this machine to Windows 10 over previous Windows, see