Audacity 2.1.2 & Win7 64bit, Bug with toolbars

I tried to move the toolbar with devices up, like I usually do with previous versions, so it takes less space. I even tried making it smaller. But it wouldn’t fit. I tried putting it elsewhere, but it insists on 3 rows. The images show it best. Strange bug, it seems.

We have made further changes to Toolbars after 2.1.2 was released. I suggest you try it in 2.1.3-alpha (see Nightly Builds) or wait for 2.1.3 to come out.


As long as you’re aware of it and fixing, I’ll wait the next version. Cheers.

We are not explicitly aware of it on Windows. There was an issue like it on Linux where Device Toolbar would not fit alongside other single-height toolbars because it was too tall, but we only fixed that for Linux.

I can fit Device Toolbar alongside other single-height toolbars on Windows 10 in 2.1.3-alpha, but I could also do so in 2.1.2 and I don’t have a very wide screen like you. So I encourage you to test in 2.1.3-alpha (nightly builds) if you want to.

Also, sometimes doing View > Toolbars > Reset Toolbars then rearranging toolbars from there can help.


Resetting didn’t help. I’d rather not use an Alpha for my recordings, so I’ll wait for next version.

It’s possible to run the alpha version as a “portable” application (no installation and no changes to your system). This is what our regular alpha testers do, so as to not interfere with their “production version” and so as to be able to compare the behaviour of multiple versions.

As a PC user, where would you place yourself on the scale “novice ↔ expert”? If more experienced than “novice”, I’d be happy to give instructions - it’s straightforward, but I appreciate that you may prefer to stick with the official release.

I’m not interested in being an alpha-tester. Especially, not for a bug so minor and obvious. No worries.