Audacity 2.1.2 will not overdub [SOLVED]

Hey guys,

Apologies if this probably noob-ish problem has been solved in the past. Searched the internet but I could not find a solution to my problem.

Audacity 2.1.2 will not let me overdub. I am trying to record from a USB interface. When I hit Rec, the cursor does not move from its position, and when I press stop, nothing shows up on the new track. Recording works fine when not overdubbing. It used to work two days ago, and I do not recall changing any setting between then and now.

Recording preferences (fiddled with those, to no avail):

Overdub: On.
Software playthrough: Off.
Audio to buffer: 100 ms.
Latency correction: -130 ms.
Sound activated recording: Off.

Device toolbar:

MME
Input: Line Audiobox USB
Stereo
Output: Speakers Audiobox USB

Project rate: 44.1 kHz
USB interface sample rate: 44.1 kHz

OS: Windows 10 Home x64
Processor: Intel Core i5 3337U 1.80 GHz
RAM: 8.00 GB

The USB interface is the only USB device plugged in. Tried disconnecting it, rebooting, uninstalling/reinstalling Audacity. Nothing worked.

Has anyone come across this problem before? I suppose I’m doing something wrong, but I can’t figure it out. Thanks in advance!

I am trying to record from a USB interface.

Which is what?

If the object is a “clean” Audacity reinstall, select reset preferences part way through. Otherwise all your preferences and settings will hang around.

Koz

a USB interface.

Without knowing anything about it past that, make sure you have Windows 10 driver software for your interface. Just “Windows” doesn’t do it. It has to say 10. And don’t use the plain Windows drivers if you can help it.

Koz

Sorry for the lack of precision. Was trying to record a synth plugged through a 3.5 jack into a PreSonus AudioBox USB.

The Audacity reinstall was a clean one, but it did not solve the problem.

I had the Windows 10 appropriate PreSonus driver for the device, but your response urged me to uninstall and reinstall it completely. Turns out that did the trick. I guess I must have changed something driver-wise without knowing it. Hope that won’t happen again.

Thanks for the help, and sorry about posting an issue so quickly solved! I’ll make sure I exhaust all options next time.