Audacity 2.1.2 Not Recording

Hi All! I’ve been trying to resolve this Audacity 2.1.2 recording issue for the past three days and all that I have read is still not working? This year I bought a Dell XPS 8900 with Windows 10 Home. It has a Realtek audio and
NVIDIA HD audio device. I have updated all my drivers for everything. I have alse activated Stereo Mix and updated the drivers for that as well.

Within Audacity properties I have the options, Host: MME, Windows DirectSound
or Windows WASAPI. For Play Back: MS Sound Mapper-output, Speakers/Headphones(Realtek Audio) or Primary Sound Driver, depending on the host settings.

For Recording: MS Sound Mapper-input, Stereo Mix(Realtek Audio),
Primary Sound Capture Driver or Speaker/Headphones(Realtek Audio) Loopback, again depending on the host settings.

I get an error when trying to use the loopback (Error while opening sound device. Please check the recording
device settings and the project sample rate.) Rate is set at 48000hz using 16 bit as per Realtek details. I have followed all the tips on this forum as well. Form what I’ve read, Stereo Mix replaces “What U Hear”?. I’ve also read
that Microsoft has excluded this capability in Windows 10. I have also read that some Win10 users are saying that Audacity works just fine? It seems that everyone here on this forum have only miner issues.

I have tried every possible configuration in Audacity Properties and still nothing works. So is that it? Is there no way Audacity is going to work on my machine? Can someone please help? Thanks in advance for any help!

If WASAPI loopback errors then you can try stereo mix instead.

Reading these links may help: (it applies to Windows 10 just the same).

WASAPI loopback may require you to set Audacity’s Device Toolbar to record in stereo, and to turn off Transport > Overdub (in the Audacity menus at the top).

Also if you have made changes in Windows Sound you must restart Audacity or you may receive “error opening sound device”.


Thanks for your reply Gale! This must be a Dell issue? I plugged in my headphone and microphone then everything started working, even with all Audacity settings. I was able to record the mic, internet and Windows Media Player and play
them back as well. But when I unplugged the mic and headphones, Audacity stopped working again? I have no idea why? Any thoughts about this?

Ok, It’s working now. Not sure why but after restarting my machine, as I have been doing, It all works. I’m using Host: MME, Recording: MS Sound Mapper-input and Play Back: Speakers/Headphones(Realtek). This issue is resolved.
Thanks for all your help.

Note that choosing “Microsoft Sound Mapper - Input” means that you are telling Audacity to record whatever is the default recording device in Windows Sound at the moment. Most people find it easier to choose the recording device directly in Audacity then you don’t have to go into Windows Sound to change.

If you get a playback or recording error in Audacity after unplugging equipment, do Transport > Rescan Audio Devices at the top of Audacity. You should not need to do that for unplugging something from the computer mic port or headphones port, but you might have to if it isn’t working properly.