Audacity 2.1.1 crashes Win 7 Pro 64-bit [SOLVED]

Uninstalled old version of Audacity and deleted config files. Downloaded Audacity 2.1.1.exe and installed. On running it crashes Windows 7 Pro 64-bit with blue screen advising “IRQL not less or equal”. The program never comes up so I can’t view “the exact three-secton version of Audacity from Help.”

That’s a kernel-mode driver error.
If it occurs when you attempt to run Audacity, then I would suspect the sound card drivers. See here for how to check and update the computer drivers: http://wiki.audacityteam.org/wiki/Updating_Sound_Device_Drivers

Updated the Realtek audio drivers to the latest version available. Rebooted the PC. Audacity still crashed the unit with the same error. Downgraded to Audacity 2.0.6. Deleted all of the config files. Rebooted the PC. Same result. System crashed with a blue screen. Though the screen only stays visible for a few seconds, I noticed one of the lines on the blue screen mentioned Etron, which means there is some sort of unpleasant interaction with the Etron USB 3.0 software for either the Extensible Host Controller, the Extensible Root Hub, the USB2 (HS) Hub (2x) or the USB3 (SS) Hub (2x). I have the latest version of that software installed.

You can use WhoCrashed to give you a very basic idea of the root cause(s) of the problem. It is worth trying in case it mentions something other than Etron, or a lower level cause.

Did you update those explicitly by going to the computer or motherboard manufacturer’s web site? That is the best practice because it should give you Realtek drivers exactly matched to your hardware.

Audacity cannot crash your PC. Most apps do not have the privileges to do that. Drivers do.

It would not hurt to reinstall the driver.

Does Device Manager show any “yellow exclamation marks” for any hardware?


Gale

Gale, thank you VERY MUCH for your suggestion about WhoCrashed. I downloaded that program, ran it, and it immediately pointed to the Etron xHCI Driver. I went to the Extron Technology webstie, downloaded the latest eXtensible Host Controller Driver, installed it, and now Audacity 2.0.6 runs as it should.

To answer your other questions, I did go to the GigaByte website to find the latest Realtek driver, but they did not offer Etron drivers at that site.

I understand that Audacity cannot crash my PC. The circumstances were such that only running Audacity led to the crash, and describing Audacity as the trigger seemed appropriate.

The determination that I had the latest Etron driver was based on Windows’ failure to find a later version. I should have known to go directly to the Etron site.

Device Manager never showed any yellow exclamation marks for any hardware during this experience.

As a final process I re-installed Audacity 2.1.1 and found that it ran as it should as well.

Altogether this has been a very pleasant experience during which, thanks to your excellent assistance, Gale, I was able to not only solve getting Audacity 2.1.1 to run, but I also added WhoCrashed to my list of valuable tools.

I’m glad you worked it out. I’ll mark the topic solved then.

Yes, Device Manager or Windows Update don’t necessarily have the latest drivers. I think they check the Windows WHQL testing database, not the manufacturer’s sources.

For motherboard audio, the “best” drivers that Windows can find are often not only slightly old, but less full-featured than the drivers on the manufacturer’s site. Sometimes, only Microsoft-supplied drivers can be found through Windows, which are obviously only generic drivers.


Gale