Audacity 2.1.1 crashes on Yosemite OS X 10.10.5


I am running audacity 2.1.0 on yosemite 10.10. I has worked pretty well for me, except… that if there is a pause in my work…. Or i change files, it crashes. Pretty much every time. I’ve ignored it for the most part, but today, i tried recording then re-recording a 17 minute section of audiobook, and before i could “export audio” to a .WAV File, it crashes. Then re-opens and offers to try and recover… but there are large holes in the files. I cannot keep re-recording until it doesn’t crash….

Why does it crash? Hopw can i prevent this please. It ir… otherwise as i said, a fine piece of software….

The topic title says 2.1.1, presumably because you posted in someone else’s topic originally. It’s always clearer to start a new topic and describe your own exact issues, although that might seem counter-intuitive.

The reason is that it gets confusing to answer different people in the same topic unless the issue and its causes really are absolutely identical. Usually they are not identical.

What type of Mac is it? What model and year?

We have never been able to recreate crashes, but most of us only have Mac minis - we suspect power management in portable Macs could be something to do with the problem.

It is best if possible to stop with one project window and one track within the same Audacity session.

So if you need to record into a second track, record the first track, save as a project, Audacity > Quit Audacity, then reopen Audacity and the project and then record the second track.

If you don’t mind recording clips into the same track, this can be done by holding SHIFT then clicking Record.

Recovery is normally very reliable, assuming the Mac itself does not crash.

If recovery is not correct, please attach the log from Help > Show Log… . Please see here for how to attach files:

Also can you look in /Applications/ for any Audacity crash reports and attach those?


I am running mac 10.10 and audacity 2.1

i have been using this program (thank you) to create audiobooks for several months successfully. However, beginning yesterday i came upon glitches that will not go away. I record an audio track (mono, single track), which averages about say 15 minutes in length.
I then “export audio” and save as a .Wav. I also save data tracks as well under an identifiable and similar name.

Later, i return to audacity, and “open” the .Wav track to edit it for pops and do-overs. What i am finding, is that minutes into the track, there are holes, skipped sentences, words missing in random places. This has happened on several files now.

I opened the .Aup tracks and found the same problem within them. Why is audacity suddenly dropping data in random places? Doeas anyone know?

Hhhmmm will see what i can do.

First of all, thank you for your reply

in partial answer, i only record one track at a time, and always mono. I save each track as an individual, so am not rteally utilizing all that audacity can do i suppose.

Attached is my audacity log from help menu. As far as crash reports, i can paste this;

Process:               Audacity [12141]
Path:                  /Applications/Audacity/
Identifier:            net.sourceforge.audacity
Responsible:           Audacity [12141]
    __TEXT                 0000000000001000-0000000000cf2000 [ 12.9M] r-x/rwx SM=COW  /Applications/Audacity/
31  net.sourceforge.audacity      	0x0047aeca wxDropSourceBase::~wxDropSourceBase() + 202
32  net.sourceforge.audacity      	0x0050db08 wxDisplayModule::~wxDisplayModule() + 264
33  net.sourceforge.audacity      	0x004e7d73 wxANIDecoder::Clone() const + 915
34  net.sourceforge.audacity      	0x005c4d9a wxHashTable::~wxHashTable() + 2026
35  net.sourceforge.audacity      	0x00042f5b std::_Deque_base<Response, std::allocator<Response> >::~_Deque_base() + 167579
36  net.sourceforge.audacity      	0x00042ed2 std::_Deque_base<Response, std::allocator<Response> >::~_Deque_base() + 167442
2   net.sourceforge.audacity      	0x000551b4 AudacityApp::~AudacityApp() + 40564
    0x1000 -   0xcf1fff +net.sourceforge.audacity ( - <BA3882CF-E6FF-00F1-4C37-52B7F09CED4B> /Applications/Audacity/

As an example and hope it’s what you seek?

I am running a macbook pro which is just a few years old.

Sadly, i have opened an additional forum with a separate, seemingly unrelated question… But perhaps the two are somehow joined. I seem to be losing small hunks of data within the individual track…

either way, at present, my audiobook recording is dead in the water for now… thank you for your help!!!
AUDACITY log.txt (4.06 KB)

Don’t shout at us in all capitals.

In video land, when someone tells us they’ve been working for a long time and suddenly it stopped working right, they’re filling up their hard drive. Are you? Your hard drive isn’t open ended; it is eventually going to fill up and they become unstable and slow when they do that.

Slow is not good. It starts leaving out parts of your performance.

Desktop > Go > Computer > Control-Click your hard drive (mine is Mackintosh HD) > Get INFO.

There is no Audacity 2.1. Which one is it really?


Please turn CAPSLOCK off. It takes extra time to reformat your text so we can read it easily. I know you are not “shouting” but many online forums would simply refuse your posts or ban you for writing in UPPER CASE.


That edited version does not show any crashed threads. Could you attach a complete report that says “Crashed thread” in it? Please see here for how to attach files:


Thank you for the log. This shows you are opening the _data folder from your “ENIGMATIC 4” project and importing individual small AU files from that folder. For example

11:41:18: File name is /Users/scottservheens/Desktop/ENIGMATIC 4_data/e00/d00/
11:41:18: Mime type is *
11:41:18: Opening with libsndfile
11:41:18: Open(/Users/scottservheens/Desktop/ENIGMATIC 4_data/e00/d00/ succeeded

Why are you doing that? Because unsaved changes to the project are not being recovered?


I merged that topic into this. I think it will be less confusing to stay in this topic.

If you launch Audacity then import a WAV file, Audacity splits the WAV into small AU files in its temporary folder. Open Audacity > Preferences… then look at Directories to see where that temporary folder is. How much disk space is shown?

Are there holes in the audio straight after you record them, that is, before you export as WAV or save as an AUP project?

When you save an AUP project file, Audacity similarly stores the data in small AU files, but in the _data folder for that project. You should not open the _data folder. Open the AUP file instead.

If you open the AUP, are there holes in the audio?

Try again after ensuring you have enough disk space. An hour of mono audio edited five times needs 3 GB of space. If you still see holes when importing a WAV file or opening an AUP file, or immediately after recording, please post the log again.


I so thank you for your patience and time with this…

I have 386 gb of space available under “directories”

i do not know if the glitches exist prior to my exporting the file to wav. In truth, as per the original post, audacity has crashed on me a few times, so i tend to “export” as soon as i am done recording in an effort to save the file. Perhaps i have to purge older files?

What i typically do is record a ‘story’ which can be from 5 to 20 minutes in length. I then either “export” that file as a wav file, and close it, then open a new file and record another, or i move to a more comfortable room/chair. And open the file and begin editing it. In the past, i have either “opened” the file, or “imported audio”, either way making a copy of the file as per the software, and working from there. When done i export the new, edited file under a new name. In the past, i have recorded a few seconds, hit pause, the recorded, then hit pause. Lately, (i’ve gotten better at reading… lol) i have simply hit record and kept it going.
The initial glitch has ocurred at 2:09 into the file, 3:32 into the file, and so on… so typically about 2 to 4 minutes into the file, and then onward from there. Perhaps the continual recording and not pausing has something to do with this? Seems odd i know… but today i will record, pause, record more, pause… and see what happens.

Typically i do not deal with the data folder or the aup file. However, in anticipation of this question, i did listen to the aup file, and it is identical to the wav file, in that it has a glitch, a skip, in the exact same spot, where the audio jumps from the middle of one sentence to another spot a second or two away (according to the script) after that moment in the recording, the glitches continue randomly.

Yesterday i deleted audacity and then re-installed it.

I am attaching a file that contains 2 short samples (seperated by me snapping my fingers). These have not been edited in anyway. These are the jumps i end up with.

Again, thank you for your time with this. I’ll keep trying things on my end

If there is a disability reason that you cannot use the SHIFT key, please respect this Forum by turning off CAPSLOCK as we have requested, and just do without the capital letter at the start of a sentence.

This will be much easier to read and save us having to manually convert your text each time.

Thank you.


Sorry. I use caps lock because its the only way my keyboard woks after I spilled coffee on it. (Unless I stop being lazy and use this bluetooth keyboard)

I went through my files and deleted all of the aup and data folder files I had amassed from earlier audiobook recordings. This added 100GB to my directory. I then re-recorded the file I am currently working on, and had another glitch at 5:02 into the file…… and then sporadically after that.

As per your reference below, I opened the Enigmatic data file ONE time, while searching for a solution to this problem. I don’t mess with those, cannot use them and merely store then collectively. I must have chosen the one section of the log that indicated that one time.

I had been hoping that deleting old files would solve this issue. Seemed logical. No such luck. I DID also record a piece then listen to it prior to trying to save or export it in any way. It too had a glitch, so the glitch is in the recording, not from the saving or storing of the information.

Here (I think) is a copy of a crash report.
CRASH FILE.txt (57.3 KB)

Thanks. It is the familiar “OSSpinLockLock” that we cannot reproduce.

Recording longer than a minute or two could be relevant to the glitches, and going away and coming back may be relevant to crashes or glitches.

The glitches in your audio sample are not long enough to be missing AU files, which makes power management or resources issues as the most likely cause of the glitches.

To attempt to address the glitches, try turning off WiFi, turn off as many other applications or services as possible, and open Audacity’s Recording Preferences and reduce “Audio to buffer” to a lower setting. You can set it at 0, then if you cannot record, increase it to 10, and so on until you find the lowest setting that will record.

Then I would suggest using Audacity > Quit Audacity, then Go > Go to Folder in Finder, and type:

~/Library/Application Support/audacity/

Save a copy of audacity.cfg which is the settings file. and attach it for us. Then delete the audcity.cfg in the “audacity” folder and restart Audacity.

If you don’t often quit Audacity, quitting regularly between your “takes” may also help reduce glitches or crashes, especially when going away for a while.