Audacity 2.0 not working on Windows 7?

For the past while, I’ve been having problems with the beta version (1.3, or something) of Audacity. It worked rather sporadically, often refusing to play anything until I undid and redid everything multiple times. It would freeze my computer, then a pop-up would appear- “error opening sound device, check output rate, blah blah”

So I uninstalled 1.3 and downloaded the new one (2.0, or whatever it’s called), from the .exe installer, which didn’t help. I keep getting that same error-message, and the program appears not to work on this computer AT ALL. I never had ANY of these problems with XP- what am I doing wrong?

The problem is most likely to be that you don’t have the Windows sound system settings right for recording.
What are you trying to record?

That’s where I was about to go. What’s the show? What are you trying to do? We can’t tell from that list of failures.

I’m just editing mp3s- I import them, make edits (change pitch, crop, whatev), and everything appears to function normally… but, when I click the Play button, I get silence and the error pop-up.

If it’s a sound issue, how do I fix it? I’ve only had this computer for a few weeks and am not familiar with Windows 7, so I have never changed the sound settings from their factory defaults… I checked the troubleshooting tips on the website, but don’t have those buttons in my control-panel. If anyone can help me fix this, I’d really appreciate it.

Specifically which pages of the web site? (links please).
Which buttons do you not have in your control panel?

I’ll post the links if I find them, but it was 5 am when I wrote the original post, so probably was looking at the wrong thing. That said, I did figure out that my computer was having issues with a bad driver- now that I’ve updated Realtek, I’m going to reinstall Audacity 2.0 and see if that works. Here’s hoping!

Okay, update…

At first, uninstalling and re-installing the sound-drivers seemed to fix the problem. Audacity actually worked, for a whole three hours- then, out of nowhere, when I tried to play a song back, I got that error message again… on something I had already played, multiple times, to make sure I’d gotten it right.

Clearly, my drivers are not the issue- maybe there’s another program or setting on my computer that Audacity doesn’t like/is incompatible with. I’m obviously doing something wrong here, but what?

Exactly what message was that? (we can’t see the error message).

From the information that we have so far I would not jump to that conclusion. It is perhaps less likely to be a driver issue.
What sort of sound card do you have?
Exactly what were you doing when the error message popped up? What was the sequence of events that lead up to the error message?

I’d not jump to that conclusion either.
We need to gather more pieces of the puzzle to work out what the picture is.

That’s all I have. Audacity works for 3 hours max, then I get that error message- closing and restarting doesn’t work, either. I’m really starting to lose my patience with the stupid thing- XP was so user-friendly; it never gave me this kind of grief.

Is the hardware that you now use to run Windows 7 exactly the same hardware that you used to run Windows XP?

Dude, just post the exact error message already. Gotta know the error description before we can even start troubleshooting.

p/s: Audacity 2.0 is working fine on my Windows 7 64-bit Home Premium, out of the box. So something’s probably off on your end.